summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorMarko Mäkelä <marko.makela@mariadb.com>2021-02-17 16:19:49 +0200
committerMarko Mäkelä <marko.makela@mariadb.com>2021-02-17 16:19:49 +0200
commit16388f393c63b3e2158db1efec8dd9625a0a295e (patch)
treef557b2818d4918582fb9a4cd61819e75c311ecc7 /debian
parentd82386b6b97b0c84094f3d1bbb0a73dbfb5113b6 (diff)
parent9d7dc1f6d0494d8c408f2c3e51a214e364783346 (diff)
downloadmariadb-git-16388f393c63b3e2158db1efec8dd9625a0a295e.tar.gz
Merge mariadb-10.5.9
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/autobake-deb.sh7
1 files changed, 7 insertions, 0 deletions
diff --git a/debian/autobake-deb.sh b/debian/autobake-deb.sh
index 43c33899d87..248537ccabb 100755
--- a/debian/autobake-deb.sh
+++ b/debian/autobake-deb.sh
@@ -70,6 +70,13 @@ then
sed "/Package: libmariadbd-dev/,/^$/d" -i debian/control
fi
+## Skip TokuDB if arch is not amd64
+if [[ ! $(dpkg-architecture -q DEB_BUILD_ARCH) =~ amd64 ]]
+then
+ sed '/Package: mariadb-plugin-tokudb/,/^$/d' -i debian/control
+fi
+
+
if [[ $(arch) =~ i[346]86 ]]
then
sed "/Package: mariadb-plugin-rocksdb/,/^$/d" -i debian/control