summaryrefslogtreecommitdiff
path: root/debian/autobake-deb.sh
diff options
context:
space:
mode:
authorOtto Kekäläinen <otto@kekalainen.net>2020-12-22 14:15:49 +0200
committerOtto Kekäläinen <otto@kekalainen.net>2020-12-23 15:17:49 +0200
commitdeecc75a025ad9ddc1e88e3400cc312263f73c60 (patch)
tree4f96b9c1440c1a6b16cd33bb86aa64366825e900 /debian/autobake-deb.sh
parentb6be78d4e5fb12447d7d2c35634902a2c0723172 (diff)
downloadmariadb-git-deecc75a025ad9ddc1e88e3400cc312263f73c60.tar.gz
Fix commit 113f18686d0 and d1809097966: PLUGIN_COLUMNSTORE=NO by default
ColumnStore seems to build by default, so it must be explicitly disabled with a build flag, so that it does not build at all and thus build machine disk space and CPU will be spared. This reverts commit 113f18686d004788f13e3a5bb60ea1c77847c963.
Diffstat (limited to 'debian/autobake-deb.sh')
-rwxr-xr-xdebian/autobake-deb.sh8
1 files changed, 4 insertions, 4 deletions
diff --git a/debian/autobake-deb.sh b/debian/autobake-deb.sh
index 0d43da12d24..e059ef8ea30 100755
--- a/debian/autobake-deb.sh
+++ b/debian/autobake-deb.sh
@@ -22,9 +22,9 @@ if [[ -d storage/columnstore/columnstore/debian ]]; then
cp -v storage/columnstore/columnstore/debian/mariadb-plugin-columnstore.* debian/
echo >> debian/control
cat storage/columnstore/columnstore/debian/control >> debian/control
- # Don't build ColumnStore as part of the native build, only build it when triggered
- # by autobake-deb.sh
- sed 's|#CMAKEFLAGS += -DPLUGIN_COLUMNSTORE=YES|CMAKEFLAGS += -DPLUGIN_COLUMNSTORE=YES|' -i debian/rules
+ # ColumnStore is explcitly disabled in the native build, so allow it now
+ # when build it when triggered by autobake-deb.sh
+ sed '/-DPLUGIN_COLUMNSTORE=NO/d' -i debian/rules
fi
# General CI optimizations to keep build output smaller
@@ -36,7 +36,7 @@ then
# MCOL-4149: ColumnStore builds are so slow and big that they must be skipped on
# both Travis-CI and Gitlab-CI
- sed 's|-DPLUGIN_COLUMNSTORE=YES|-DPLUGIN_COLUMNSTORE=NO|' -i debian/rules
+ sed 's|$(CMAKEFLAGS)|$(CMAKEFLAGS) -DPLUGIN_COLUMNSTORE=NO|' -i debian/rules
sed "/Package: mariadb-plugin-columnstore/,/^$/d" -i debian/control
fi