summaryrefslogtreecommitdiff
path: root/debian/autobake-deb.sh
diff options
context:
space:
mode:
authorMarko Mäkelä <marko.makela@mariadb.com>2021-04-14 10:33:59 +0300
committerMarko Mäkelä <marko.makela@mariadb.com>2021-04-14 10:33:59 +0300
commit5008171b05e0d3b8b5f4af312b94a312281e77c7 (patch)
tree4a551df68976e937d18a7416d799c7a5605cb12f /debian/autobake-deb.sh
parent61f84bba603aa85957b48d151f9ddf5ba4e71ab1 (diff)
parent13d0641710802bd57b0c0d88c9fc321932014994 (diff)
downloadmariadb-git-5008171b05e0d3b8b5f4af312b94a312281e77c7.tar.gz
Merge 10.3 into 10.4
Diffstat (limited to 'debian/autobake-deb.sh')
-rwxr-xr-xdebian/autobake-deb.sh9
1 files changed, 9 insertions, 0 deletions
diff --git a/debian/autobake-deb.sh b/debian/autobake-deb.sh
index 5ace5ea0a05..a8b1010643b 100755
--- a/debian/autobake-deb.sh
+++ b/debian/autobake-deb.sh
@@ -111,6 +111,15 @@ then
sed '/Package: mariadb-plugin-cassandra/,/^$/d' -i debian/control
fi
+# From Debian Stretch/Ubuntu Bionic onwards dh-systemd is just an empty
+# transitional metapackage and the functionality was merged into debhelper.
+# In Ubuntu Hirsute is was completely removed, so it can't be referenced anymore.
+# Keep using it only on Debian Jessie and Ubuntu Xenial.
+if apt-cache madison dh-systemd | grep 'dh-systemd' >/dev/null 2>&1
+then
+ sed 's/debhelper (>= 9.20160709~),/debhelper (>= 9), dh-systemd,/' -i debian/control
+fi
+
# Mroonga, TokuDB never built on Travis CI anyway, see build flags above
if [[ $TRAVIS ]]
then