summaryrefslogtreecommitdiff
path: root/debian/autobake-deb.sh
diff options
context:
space:
mode:
authorOtto Kekäläinen <otto@mariadb.org>2016-10-29 02:43:45 +0300
committerOtto Kekäläinen <otto@mariadb.org>2016-10-29 03:50:11 +0300
commitc912d05fab9db5829c403432fddece257c75ece0 (patch)
tree01eb9869279006802255e32f1cf73f7aee5bebb3 /debian/autobake-deb.sh
parent7316b14144ceeed40dc976b9b5f2aa97f07a3eb3 (diff)
downloadmariadb-git-c912d05fab9db5829c403432fddece257c75ece0.tar.gz
MDEV-6284: Install systemd files (almost) the Debian way
The control file contents must be correct from the start and cannot be modified at build time by CMake. Also all static Debian package analyzers will fail to see all manipulations by CMake later on. It is best to do all manipulations like these in autobake-deb.sh.
Diffstat (limited to 'debian/autobake-deb.sh')
-rwxr-xr-xdebian/autobake-deb.sh14
1 files changed, 14 insertions, 0 deletions
diff --git a/debian/autobake-deb.sh b/debian/autobake-deb.sh
index f8d313204d2..1201e28009f 100755
--- a/debian/autobake-deb.sh
+++ b/debian/autobake-deb.sh
@@ -60,6 +60,20 @@ then
sed '/libpcre3-dev/d' -i debian/control
fi
+# If libsystemd-dev is not available (before Debian Jessie or Ubuntu Wily)
+# clean away the systemd stanzas so the package can build without them.
+if ! apt-cache madison libsystemd-dev | grep 'libsystemd-dev' >/dev/null 2>&1
+then
+ sed '/dh-systemd/d' -i debian/control
+ sed '/libsystemd-dev/d' -i debian/control
+ sed 's/ --with systemd//' -i debian/rules
+ sed '/systemd/d' -i debian/rules
+ sed '/\.service/d' -i debian/rules
+ sed '/galera_new_cluster/d' -i debian/mariadb-server-10.2.install
+ sed '/galera_recovery/d' -i debian/mariadb-server-10.2.install
+ sed '/mariadb-service-convert/d' -i debian/mariadb-server-10.2.install
+fi
+
# On Travis-CI, the log must stay under 4MB so make the build less verbose
if [[ $TRAVIS ]]
then