summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <msvensson@pilot.(none)>2007-06-04 16:42:42 +0200
committerunknown <msvensson@pilot.(none)>2007-06-04 16:42:42 +0200
commit1bf52d4735fded85e3412c1fff6f393c6fc50c36 (patch)
treeb766785bc20f902adef60929ade6ea0795e3a4b5 /configure.in
parente3a24797fdc7768cc457fa05a668be60580d7f7d (diff)
downloadmariadb-git-1bf52d4735fded85e3412c1fff6f393c6fc50c36.tar.gz
Bug#10218 Command line recall rolls into Segmentation Fault(coredump)'
- Declare 'tgoto' if not already declared in system header files. cmd-line-utils/libedit/el_term.h: Declare 'tgoto' if not already declared in system header files. Failing to declare it will cause the pointer returned to be truncated to 32-bit integer which is no a valid pointer - in most cases. configure.in: Add check to see if 'tgoto' is declared in system header files
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index b9f84086e28..dd3b449f9c8 100644
--- a/configure.in
+++ b/configure.in
@@ -1954,6 +1954,19 @@ else
fi
AC_SUBST(TERMCAP_LIB)
+# Check if the termcap function 'tgoto' is already declared in
+# system header files or if it need to be declared locally
+AC_CHECK_DECLS(tgoto,,,[
+#ifdef HAVE_CURSES_H
+# include <curses.h>
+#elif HAVE_NCURSES_H
+# include <ncurses.h>
+#endif
+#ifdef HAVE_TERM_H
+# include <term.h>
+#endif
+])
+
LIBEDIT_LOBJECTS=""
AC_CHECK_FUNC(strunvis, ,[LIBEDIT_LOBJECTS="$LIBEDIT_LOBJECTS unvis.o"])
AC_CHECK_FUNC(strvis, ,[LIBEDIT_LOBJECTS="$LIBEDIT_LOBJECTS vis.o"])