summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorGeorgi Kodinov <Georgi.Kodinov@Oracle.com>2010-10-29 14:02:49 +0300
committerGeorgi Kodinov <Georgi.Kodinov@Oracle.com>2010-10-29 14:02:49 +0300
commitfd46de026d59c97e2e1628a252b71744c1e877da (patch)
tree298a4692281c6b166983dadf8cf3ba8067115956 /configure.in
parent64044fdf19f2b7c75f864156cc65db0026171527 (diff)
parent23552ecd41ec6679fd90f57ad982db8abf09c4ea (diff)
downloadmariadb-git-fd46de026d59c97e2e1628a252b71744c1e877da.tar.gz
merge to 5.1-security
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in19
1 files changed, 14 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index 7680a60226a..b7cd3585789 100644
--- a/configure.in
+++ b/configure.in
@@ -103,6 +103,13 @@ AC_SUBST(SHARED_LIB_MAJOR_VERSION)
AC_SUBST(SHARED_LIB_VERSION)
AC_SUBST(AVAILABLE_LANGUAGES)
+# Check whether a debug mode should be enabled.
+AC_ARG_WITH([debug],
+ AS_HELP_STRING([--with-debug@<:@=full@:>@],
+ [Enable various amounts of debugging support (full adds a slow memory checker).]),
+ [with_debug=$withval],
+ [with_debug=no])
+
# Whether the maintainer mode should be enabled.
MY_MAINTAINER_MODE
@@ -1674,11 +1681,6 @@ then
DEBUG_OPTIMIZE_CXX=""
fi
-AC_ARG_WITH(debug,
- [ --with-debug Add debug code
- --with-debug=full Add debug code (adds memory checker, very slow)],
- [with_debug=$withval],
- [with_debug=no])
if test "$with_debug" = "yes"
then
# Medium debug.
@@ -2071,6 +2073,13 @@ MYSQL_TYPE_QSORT
AC_FUNC_UTIME_NULL
AC_FUNC_VPRINTF
+AC_CHECK_DECLS([fdatasync],,,
+[
+#ifdef HAVE_UNISTD_H
+# include <unistd.h>
+#endif
+])
+
AC_CHECK_FUNCS(alarm bfill bmove bsearch bzero \
chsize cuserid fchmod fcntl \
fconvert fdatasync fesetround finite fpresetsticky fpsetmask fsync ftruncate \