summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <monty@hundin.mysql.fi>2001-09-21 16:36:23 +0300
committerunknown <monty@hundin.mysql.fi>2001-09-21 16:36:23 +0300
commit84e8e1fe39c5e0d44bbafb2d77924661161a4ae6 (patch)
tree08d42f4dfab1e2188ad35fbd09ffd078803b70ed /configure.in
parent8c2f8385dbb4f607596a6189e04262c0400f0f75 (diff)
downloadmariadb-git-84e8e1fe39c5e0d44bbafb2d77924661161a4ae6.tar.gz
Fixes for distributed build
Changed --do-pstack to --enable-pstack Removed pstack from default build client/Makefile.am: Fixes for distributed build configure.in: Removed pstack from default build sql/Makefile.am: Fixes for distributed build sql/mysqld.cc: Changed --do-pstack to --enable-pstack
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 6 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index b121d641fe4..14816515e97 100644
--- a/configure.in
+++ b/configure.in
@@ -699,9 +699,9 @@ int main()
AC_MSG_RESULT($atom_ops)
AC_ARG_WITH(pstack,
- [ --without-pstack Do not use the pstack backtrace library],
- [USE_PSTACK=$withval],
- [USE_PSTACK=yes])
+ [ --with-pstack Use the pstack backtrace library],
+ [ USE_PSTACK=$withval ],
+ [ USE_PSTACK=no ])
pstack_libs=
pstack_dirs=
if test "$USE_PSTACK" = yes -a "$IS_LINUX" = "true" -a "$BASE_MACHINE_TYPE" = "i386" -a "$with_mit_threads" = "no"
@@ -717,7 +717,9 @@ dnl I have no idea if this is a good test - can not find docs for libiberty
if test x"$have_libiberty" = xyes -a x"$have_libbfd" = xyes
then
pstack_dirs='$(top_srcdir)'/pstack
- pstack_libs="$pstack_dirs/libpstack.a -lbfd -liberty"
+ pstack_libs="../pstack/libpstack.a -lbfd -liberty"
+ # We must link staticly when using pstack
+ with_mysqld_ldflags="-all-static"
AC_SUBST([pstack_dirs])
AC_SUBST([pstack_libs])
AC_DEFINE([USE_PSTACK])