summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <pappa@c-8808e253.1238-1-64736c10.cust.bredbandsbolaget.se>2006-03-21 10:44:59 -0500
committerunknown <pappa@c-8808e253.1238-1-64736c10.cust.bredbandsbolaget.se>2006-03-21 10:44:59 -0500
commit88a1cff6efa23159644fba475424e83d3a313c45 (patch)
tree5876aed6e233ea5e55356a926f07cf3cb8ec443c /configure.in
parentb3bdc112688fda9784e7f38073cce28063bb832b (diff)
parent26416bf5448f45a171fb1e0e28c425f401b1a0aa (diff)
downloadmariadb-git-88a1cff6efa23159644fba475424e83d3a313c45.tar.gz
Merge c-8808e253.1238-1-64736c10.cust.bredbandsbolaget.se:/home/pappa/mysql-5.1-new
into c-8808e253.1238-1-64736c10.cust.bredbandsbolaget.se:/home/pappa/wl2826 configure.in: Auto merged dbug/dbug.c: Auto merged include/my_sys.h: Auto merged sql/ha_ndbcluster.cc: Auto merged sql/ha_ndbcluster.h: Auto merged sql/ha_partition.h: Auto merged sql/mysql_priv.h: Auto merged sql/set_var.cc: Auto merged sql/sql_base.cc: Auto merged sql/sql_class.cc: Auto merged sql/sql_class.h: Auto merged sql/sql_partition.cc: Auto merged sql/sql_table.cc: Auto merged sql/sql_yacc.yy: Auto merged sql/table.cc: Auto merged sql/unireg.cc: Auto merged sql/ha_heap.cc: manual merge sql/ha_myisammrg.cc: manual merge sql/ha_partition.cc: manual merge sql/handler.h: manual merge sql/log.cc: manual merge sql/mysqld.cc: manual merge sql/share/errmsg.txt: manual merge
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 21bf9559245..d152b82abc9 100644
--- a/configure.in
+++ b/configure.in
@@ -666,6 +666,7 @@ else
AC_MSG_RESULT([no])
fi
+
MYSQL_SYS_LARGEFILE
# Types that must be checked AFTER large file support is checked
@@ -1566,6 +1567,18 @@ then
DEBUG_OPTIMIZE_CXX=""
fi
+# If we should allow error injection tests
+AC_ARG_WITH(error-inject,
+ [ --with-error-inject Enable error injection in MySQL Server],
+ [ with_error_inject=$withval ],
+ [ with_error_inject=no ])
+
+if test "$with_error_inject" = "yes"
+then
+ CFLAGS="-DERROR_INJECT_SUPPORT $CFLAGS"
+ CXXFLAGS="-DERROR_INJECT_SUPPORT $CXXFLAGS"
+fi
+
AC_ARG_WITH(debug,
[ --with-debug Add debug code
--with-debug=full Add debug code (adds memory checker, very slow)],