summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <tim@localhost.polyesthetic.msg>2000-08-22 16:09:27 -0400
committerunknown <tim@localhost.polyesthetic.msg>2000-08-22 16:09:27 -0400
commit06c58585384bc7730e518e93bd8efa306158aa2e (patch)
tree0033103c62fb7ee4a3104232ccd035bc6be1275c /configure.in
parent11f402b3108b0c6ef5744bd13164607dd9fba3c0 (diff)
parentdb3b3c1799d111a22c5aaead6426b7f064ea8fd9 (diff)
downloadmariadb-git-06c58585384bc7730e518e93bd8efa306158aa2e.tar.gz
Merge tim@work:/home/bk/mysql
into localhost.polyesthetic.msg:/usr/local/src/my/work configure.in: Auto merged
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in15
1 files changed, 4 insertions, 11 deletions
diff --git a/configure.in b/configure.in
index d2f7b0486ee..a65580c9699 100644
--- a/configure.in
+++ b/configure.in
@@ -1577,15 +1577,6 @@ do
See the Installation chapter in the Reference Manual.]);
fi
done
-
-default_charset_has_source=0
-for cs in $COMPILED_CHARSETS
-do
- if test $cs = $default_charset
- then
- default_charset_has_source=1
- fi
-done
CHARSET_SRCS=""
CHARSETS_NEED_SOURCE=""
@@ -1600,8 +1591,10 @@ index_file="$srcdir/sql/share/charsets/Index"
for c in $CHARSETS
do
# get the charset number from $index_file
- subpat='^'"${c}"'[[\t ]]*#'
- number=`$AWK 'sub("'"$subpat"'", "") { print }' $index_file`
+changequote(,)dnl
+ subpat='^'"${c}"'[ ][ ]*\([0-9][0-9]*\)[^0-9]*$'
+ number=`sed -e "/$subpat/!d" -e 's//\1/' $index_file`
+changequote([,])dnl
# some sanity checking....
if test X"$number" = X
then