summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <tim@siva.hindu.god>2004-11-02 17:53:25 -0700
committerunknown <tim@siva.hindu.god>2004-11-02 17:53:25 -0700
commit1d3f4a1a490656378131d66cb507145e5141fbdd (patch)
tree4d42cfcc0328f842a6db1b61728953204bde676e /configure.in
parent9c06c80dff5744ac0b1d214404c9d16f752e41bb (diff)
downloadmariadb-git-1d3f4a1a490656378131d66cb507145e5141fbdd.tar.gz
Portability fixes to mysqld_safe for non-Linux systems. Fix FIND_PROC
for Solaris test, and fix if @IS_LINUX@ test in mysqld_safe itself. configure.in: Portability fix for FIND_PROC setting; on Solaris (and probably others), 'ps -p $$' inside a shell script just returns 'sh' for command line, even though $0 contains the filename. So, use 'ps -fp $$' in the test (it shows the full command line, e.g., 'sh configure'). Leave the actual FIND_PROC command as-is, since mysqld itself is not a shell script. scripts/mysqld_safe.sh: Portability fix for mysqld_safe on non-Linux systems. A bogus use of 'if' and 'test' caused non-bash shells to enter a section meant to be run only on Linux systems. BitKeeper/etc/logging_ok: Logging to logging@openlogging.org accepted
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index d4ede468435..97a59258ba8 100644
--- a/configure.in
+++ b/configure.in
@@ -444,7 +444,7 @@ if $PS p $$ 2> /dev/null | grep $0 > /dev/null
then
FIND_PROC="$PS p \$\$PID | grep mysqld > /dev/null"
# Solaris
-elif $PS -p $$ 2> /dev/null | grep $0 > /dev/null
+elif $PS -fp $$ 2> /dev/null | grep $0 > /dev/null
then
FIND_PROC="$PS -p \$\$PID | grep mysqld > /dev/null"
# BSD style