summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorkent@mysql.com/kent-amd64.(none) <>2007-09-27 21:39:23 +0200
committerkent@mysql.com/kent-amd64.(none) <>2007-09-27 21:39:23 +0200
commit96b62a5c133845b270fc859fd864782ec18f1897 (patch)
treef1f721c659cf65293472074a09059c20919ae68a /configure.in
parent1e5c06ea3470ee2158a1e72599a4c3bc024394a3 (diff)
downloadmariadb-git-96b62a5c133845b270fc859fd864782ec18f1897.tar.gz
Makefile.am, configure.in:
Handle pstack like other optional directories Check if a directory exists relative to $srcdir
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 6 insertions, 7 deletions
diff --git a/configure.in b/configure.in
index af5cf1b6d0a..e8693f1fa71 100644
--- a/configure.in
+++ b/configure.in
@@ -838,7 +838,7 @@ if test "$TARGET_LINUX" = "true"; then
[ USE_PSTACK=$withval ],
[ USE_PSTACK=no ])
pstack_libs=
- pstack_dirs=
+ pstack_dir=
if test "$USE_PSTACK" = yes -a "$TARGET_LINUX" = "true" -a "$BASE_MACHINE_TYPE" = "i386"
then
have_libiberty= have_libbfd=
@@ -851,11 +851,11 @@ dnl I have no idea if this is a good test - can not find docs for libiberty
if test x"$have_libiberty" = xyes -a x"$have_libbfd" = xyes
then
- pstack_dirs='$(top_srcdir)'/pstack
+ pstack_dir="pstack"
pstack_libs="../pstack/libpstack.a -lbfd -liberty"
# We must link staticly when using pstack
with_mysqld_ldflags="-all-static"
- AC_SUBST([pstack_dirs])
+ AC_SUBST([pstack_dir])
AC_SUBST([pstack_libs])
AC_DEFINE([USE_PSTACK], [1], [the pstack backtrace library])
dnl This check isn't needed, but might be nice to give some feedback....
@@ -869,7 +869,6 @@ dnl have_libiberty_h=no)
USE_PSTACK="no"
fi
fi
-AM_CONDITIONAL(COMPILE_PSTACK, test "$USE_PSTACK" = "yes")
AC_MSG_CHECKING([if we should use pstack])
AC_MSG_RESULT([$USE_PSTACK])
@@ -2430,7 +2429,7 @@ else
MYSQL_CHECK_NEW_RL_INTERFACE
MYSQL_CHECK_READLINE_DECLARES_HIST_ENTRY
AC_LANG_RESTORE
- if [test "$mysql_cv_new_rl_interface" = "yes"] && [test -d "./cmd-line-utils/readline"]
+ if [test "$mysql_cv_new_rl_interface" = "yes"] && [test -d "$srcdir/cmd-line-utils/readline"]
then
# Use the new readline interface, but only if the package includes a bundled libreadline
# this way we avoid linking commercial source with GPL readline
@@ -2617,10 +2616,10 @@ esac
AC_SUBST(MAKE_BINARY_DISTRIBUTION_OPTIONS)
# Output results
-if test -d "pstack" ; then
+if test -d "$srcdir/pstack" ; then
AC_CONFIG_FILES(pstack/Makefile pstack/aout/Makefile)
fi
-if test -d "cmd-line-utils/readline" ; then
+if test -d "$srcdir/cmd-line-utils/readline" ; then
AC_CONFIG_FILES(cmd-line-utils/readline/Makefile)
fi