summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <tomas@poseidon.bredbandsbolaget.se>2004-06-11 23:39:10 +0000
committerunknown <tomas@poseidon.bredbandsbolaget.se>2004-06-11 23:39:10 +0000
commit5aec1bfa289334ea9eb33dd6797cafe4bc386091 (patch)
tree61a1c23580ca7fd4926ad638bb8e706516735547 /configure.in
parentfe94000324e6f7349c508dae9ba5b6d2856f742e (diff)
parent387fb31040f65f5a8a9df89d5e89f51767fe94b3 (diff)
downloadmariadb-git-5aec1bfa289334ea9eb33dd6797cafe4bc386091.tar.gz
Merge tulin@bk-internal.mysql.com:/home/bk/mysql-4.1
into poseidon.bredbandsbolaget.se:/home/tomas/mysql-4.1 configure.in: Auto merged
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 5 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index c1e3f9ff961..a7943a8410b 100644
--- a/configure.in
+++ b/configure.in
@@ -370,12 +370,15 @@ AC_SUBST(INSTALL_SCRIPT)
export CC CXX CFLAGS LD LDFLAGS AR
+ndb_cxxflags_fix=
if test "$GXX" = "yes"
then
# mysqld requires -fno-implicit-templates.
# Disable exceptions as they seams to create problems with gcc and threads.
# mysqld doesn't use run-time-type-checking, so we disable it.
CXXFLAGS="$CXXFLAGS -fno-implicit-templates -fno-exceptions -fno-rtti"
+ # ndb cannot be compiled with -fno-implicit-templaces
+ ndb_cxxflags_fix=-fimplicit-templates
# If you are using 'gcc' 3.0 (not g++) to compile C++ programs on Linux,
# we will gets some problems when linking static programs.
@@ -2892,21 +2895,20 @@ if test X"$have_ndbcluster" = Xyes
then
MAKE_BINARY_DISTRIBUTION_OPTIONS="$MAKE_BINARY_DISTRIBUTION_OPTIONS --with-ndbcluster"
+ CXXFLAGS="$CXXFLAGS \$(NDB_CXXFLAGS)"
if test "$with_debug" = "yes"
then
# Medium debug.
NDB_DEFS="-DVM_TRACE -DERROR_INSERT -DARRAY_GUARD"
- CXXFLAGS="$CXXFLAGS \$(NDB_CXXFLAGS) \$(NDB_CXXFLAGS_LOC) \$(NDB_CXXFLAGS_DEBUG_LOC)"
elif test "$with_debug" = "full"
then
NDB_DEFS="-DVM_TRACE -DERROR_INSERT -DARRAY_GUARD"
- CXXFLAGS="$CXXFLAGS \$(NDB_CXXFLAGS) \$(NDB_CXXFLAGS_LOC) \$(NDB_CXXFLAGS_DEBUG_LOC)"
else
NDB_DEFS="-DNDEBUG"
- CXXFLAGS="$CXXFLAGS \$(NDB_CXXFLAGS) \$(NDB_CXXFLAGS_LOC) \$(NDB_CXXFLAGS_RELEASE_LOC)"
fi
AC_SUBST([NDB_DEFS])
+AC_SUBST([ndb_cxxflags_fix])
ndb_transporter_opt_objs=""
if test X"$have_ndb_shm" = Xyes