summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <monty@mashka.mysql.fi>2003-10-16 20:55:15 +0300
committerunknown <monty@mashka.mysql.fi>2003-10-16 20:55:15 +0300
commit4f936a69a798483b318fad4124641256eb0ce380 (patch)
tree15abb95c73d02f77be5ffd9d90398f905401d815 /configure.in
parent8ddb4b7c553508fbf48fb3026909a35bac98d32e (diff)
downloadmariadb-git-4f936a69a798483b318fad4124641256eb0ce380.tar.gz
Safety fix to detect multiple calls to my_thread_end()
Portability fix (For Mac OS X) configure.in: Added detection of malloc / sys/malloc include/my_pthread.h: Safety fix to detect multiple calls to my_thread_end() libmysqld/lib_sql.cc: Remove duplicate call to my_thread_end() mysys/charset.c: Cleanup indentation Remove some short variable names mysys/my_thr_init.c: Safety fix to detect multiple calls to my_thread_end() sql/sql_test.cc: Portability fix (For Mac OS X)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index f085d365ed2..8ce3a9aea67 100644
--- a/configure.in
+++ b/configure.in
@@ -733,7 +733,7 @@ AC_CHECK_HEADERS(fcntl.h float.h floatingpoint.h ieeefp.h limits.h \
strings.h string.h synch.h sys/mman.h sys/socket.h netinet/in.h arpa/inet.h \
sys/timeb.h sys/types.h sys/un.h sys/vadvise.h sys/wait.h term.h \
unistd.h utime.h sys/utime.h termio.h termios.h sched.h crypt.h alloca.h \
- sys/ioctl.h)
+ sys/ioctl.h malloc.h sys/malloc.h)
#--------------------------------------------------------------------
# Check for system libraries. Adds the library to $LIBS