summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDavi Arnaut <davi.arnaut@oracle.com>2010-10-18 15:38:32 -0200
committerDavi Arnaut <davi.arnaut@oracle.com>2010-10-18 15:38:32 -0200
commitc903377d1eba7e6eb0ec532fe470fe09ad292fc7 (patch)
tree4d0227ce8642b3270ca6cbdb19db2c45f693f993 /configure.in
parent4053a5a44832552090218fb7ca685c1c2a2ae006 (diff)
parent5aa81e380cde5bc9f9cd42787286d6db5292d631 (diff)
downloadmariadb-git-c903377d1eba7e6eb0ec532fe470fe09ad292fc7.tar.gz
Merge of mysql-5.1-bugteam into mysql-5.5-bugteam.
CMakeLists.txt: Enable the maintainer mode if debug support is enabled. Does not cause it to be enabled if the user explicitly disabled the maintainer mode.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 7 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 4725008b473..81dd853a455 100644
--- a/configure.in
+++ b/configure.in
@@ -118,6 +118,13 @@ AC_SUBST(SHARED_LIB_MAJOR_VERSION)
AC_SUBST(SHARED_LIB_VERSION)
AC_SUBST(AVAILABLE_LANGUAGES)
+# Check whether a debug mode should be enabled.
+AC_ARG_WITH([debug],
+ AS_HELP_STRING([--with-debug@<:@=full@:>@],
+ [Enable various amounts of debugging support (full adds a slow memory checker).]),
+ [with_debug=$withval],
+ [with_debug=no])
+
# Whether the maintainer mode should be enabled.
MY_MAINTAINER_MODE
@@ -1689,10 +1696,6 @@ then
DEBUG_OPTIMIZE_CXX=""
fi
-AC_ARG_WITH(debug,
- [AS_HELP_STRING([--with-debug], [Add debug code @<:@default=no@:>@])],
- [with_debug=$withval],
- [with_debug=no])
if test "$with_debug" = "yes"
then
AC_DEFINE([DBUG_ON], [1], [Use libdbug])