summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <monty@work.mysql.com>2001-07-18 23:58:10 +0200
committerunknown <monty@work.mysql.com>2001-07-18 23:58:10 +0200
commit61c04f0e9c934455eddef0cb97f2f8950980c131 (patch)
treefb907efd0b1549145b9fc6f82ddd7107f4ab8a55 /configure.in
parent90acfb9ff36c796650b40c8b85f2f4042c60d1fc (diff)
parentdece009c8b84f6ee60cf43e32931debc361b932c (diff)
downloadmariadb-git-61c04f0e9c934455eddef0cb97f2f8950980c131.tar.gz
merge
myisam/mi_check.c: Auto merged myisam/myisamchk.c: Auto merged sql/mysqld.cc: Auto merged mysql-test/t/bdb.test: Auto merged sql/slave.cc: Auto merged sql/sql_delete.cc: Auto merged sql/sql_insert.cc: Auto merged sql/sql_parse.cc: Auto merged sql/sql_show.cc: Auto merged sql/sql_update.cc: Auto merged configure.in: New version
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in30
1 files changed, 22 insertions, 8 deletions
diff --git a/configure.in b/configure.in
index d9c443c0dc8..381ba7c9299 100644
--- a/configure.in
+++ b/configure.in
@@ -629,7 +629,10 @@ struct request_info *req;
AC_MSG_RESULT(yes)
AC_DEFINE(LIBWRAP)
AC_DEFINE(HAVE_LIBWRAP)
- WRAPLIBS="-L$with_libwrap/lib -lwrap",
+ if test "$with_libwrap" != "yes"; then
+ WRAPLIBS="-L${with_libwrap}/lib"
+ fi
+ WRAPLIBS="${WRAPLIBS} -lwrap",
AC_MSG_RESULT(no)
CPPFLAGS=${_cppflags} LDFLAGS=${_ldflags}),
CPPFLAGS=${_cppflags} LDFLAGS=${_ldflags})
@@ -831,6 +834,12 @@ case $SYSTEM_TYPE in
echo "Adding fix for interrupted reads"
CXXFLAGS="$CXXFLAGS -DMYSQLD_NET_RETRY_COUNT=1000000"
;;
+ *netbsd*)
+ echo "Adding flag -Dunix"
+ CFLAGS="$CFLAGS -Dunix"
+ CXXFLAGS="$CXXFLAGS -Dunix"
+ OVERRIDE_MT_LD_ADD="\$(top_srcdir)/mit-pthreads/obj/libpthread.a"
+ ;;
*bsdi*)
echo "Adding fix for BSDI"
CFLAGS="$CFLAGS -D__BSD__ -DHAVE_BROKEN_REALPATH"
@@ -1155,10 +1164,10 @@ if test "$ac_cv_lib_pthread_strtok_r" = "no"
then
my_save_LIBS="$LIBS"
AC_CHECK_LIB(c_r,strtok_r)
- if test "$with_osf32_threads" = "yes" -o "$target_os" = "FreeBSD" -o "$target_os" = "freebsd"
- then
- LIBS="$my_save_LIBS"
- fi
+ case "$with_osf32_threads---$target_os" in
+ # Don't keep -lc_r in LIBS; -pthread handles it magically
+ yes---* | *---freebsd* ) LIBS="$my_save_LIBS" ;;
+ esac
AC_CHECK_FUNCS(strtok_r pthread_init)
else
AC_CHECK_FUNCS(strtok_r)
@@ -2058,7 +2067,7 @@ and GNU make work together causes some files to depend on this
header, even if we're not building with Berkeley DB.
Obviously, if this file *is* used, it'll break and hopefully we can find
-out why this file was generated by $(top_srcdir)/configure instead of
+out why this file was generated by ${top_srcdir}/configure instead of
the real db.h.
If you run into some problems because of this file, please use mysql_bug
@@ -2099,15 +2108,20 @@ EOF
AC_DEFINE(HAVE_mit_thread)
MT_INCLUDES="-I\$(top_srcdir)/mit-pthreads/include"
AC_SUBST(MT_INCLUDES)
- MT_LD_ADD="-L \$(top_srcdir)/mit-pthreads/obj/ -lpthread"
+ if test -n "$OVERRIDE_MT_LD_ADD"
+ then
+ MT_LD_ADD="$OVERRIDE_MT_LD_ADD"
+ else
+ MT_LD_ADD="-L \$(top_srcdir)/mit-pthreads/obj/ -lpthread"
+ fi
AC_SUBST(MT_LD_ADD)
- LIBS="$MT_LD_ADD $LIBS"
echo ""
echo "Configuring MIT Pthreads"
# We will never install so installation paths are not needed.
(cd mit-pthreads; sh ./configure)
echo "End of MIT Pthreads configuration"
echo ""
+ LIBS="$MT_LD_ADD $LIBS"
fi
fi
AC_SUBST(sql_server_dirs)