summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authormonty@hundin.mysql.fi <>2001-11-04 16:14:09 +0200
committermonty@hundin.mysql.fi <>2001-11-04 16:14:09 +0200
commitfd0780493d9f91c1b4e8a0ff80fc670d5cf3b19a (patch)
tree689c9d0271e23431f1ab0ac09e1af4d68a58ca76 /configure.in
parent67951fdeb4195d6fcefeba6aab811b6c5e585178 (diff)
parent65d4c846d83467270e56537b2cd0f44fc37ef9be (diff)
downloadmariadb-git-fd0780493d9f91c1b4e8a0ff80fc670d5cf3b19a.tar.gz
merge with 3.23.44
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index b3927ac6961..d2f5eee5c23 100644
--- a/configure.in
+++ b/configure.in
@@ -4,7 +4,7 @@ dnl Process this file with autoconf to produce a configure script.
AC_INIT(sql/mysqld.cc)
AC_CANONICAL_SYSTEM
# The Docs Makefile.am parses this line!
-AM_INIT_AUTOMAKE(mysql, 4.0.0-alpha)
+AM_INIT_AUTOMAKE(mysql, 4.0.1-alpha)
AM_CONFIG_HEADER(config.h)
PROTOCOL_VERSION=10
@@ -1318,6 +1318,12 @@ AC_ARG_WITH(client-ldflags,
[CLIENT_EXTRA_LDFLAGS=])
AC_SUBST(CLIENT_EXTRA_LDFLAGS)
+AC_ARG_WITH(lib-ccflags,
+ [ --with-lib-ccflags Extra CC options for libraries],
+ [LIB_EXTRA_CCFLAGS=$withval],
+ [LIB_EXTRA_CCFLAGS=])
+AC_SUBST(LIB_EXTRA_CCFLAGS)
+
# Avoid stupid bug on some OS
AC_ARG_WITH(low-memory,
[ --with-low-memory Try to use less memory to compile to avoid