summaryrefslogtreecommitdiff
path: root/client/CMakeLists.txt
diff options
context:
space:
mode:
authordf@pippilotta.erinye.com <>2007-08-03 14:43:11 +0200
committerdf@pippilotta.erinye.com <>2007-08-03 14:43:11 +0200
commit5ad3f6083e11e34fc3631bdf8803eb9679416b8c (patch)
treefff6bcd4ed4a369807eb8d0c2db633523f8fc794 /client/CMakeLists.txt
parent481cb830d13bbd7c5f5f4fe1e5a2251cb69ce1bd (diff)
downloadmariadb-git-5ad3f6083e11e34fc3631bdf8803eb9679416b8c.tar.gz
add mysqlslap back to windows builds for 5.1
Diffstat (limited to 'client/CMakeLists.txt')
-rwxr-xr-xclient/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/client/CMakeLists.txt b/client/CMakeLists.txt
index 0b37f4d3d1c..2ef55c23c90 100755
--- a/client/CMakeLists.txt
+++ b/client/CMakeLists.txt
@@ -63,6 +63,10 @@ TARGET_LINK_LIBRARIES(mysqlbinlog mysqlclient_notls wsock32)
ADD_EXECUTABLE(mysqladmin mysqladmin.cc)
TARGET_LINK_LIBRARIES(mysqladmin mysqlclient_notls wsock32)
+ADD_EXECUTABLE(mysqlslap mysqlslap.c)
+SET_SOURCE_FILES_PROPERTIES(mysqlslap.c PROPERTIES COMPILE_FLAGS "-DTHREADS")
+TARGET_LINK_LIBRARIES(mysqlslap mysqlclient mysys zlib wsock32 dbug)
+
ADD_EXECUTABLE(echo echo.c)
IF(EMBED_MANIFESTS)