summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorkent@mysql.com <>2005-08-28 20:03:03 +0200
committerkent@mysql.com <>2005-08-28 20:03:03 +0200
commit88af3ceb2009a2d735ff3ae90abd5ae0b84bb6c0 (patch)
tree1818c39a8eb9c298f913db3b9ff5bf5ec1f42629 /Makefile.am
parent5b35789d12b89cdc5f3811eea19fc7f642bfcabb (diff)
parente2954b29a12f071023c2a75190bad8ba9f980298 (diff)
downloadmariadb-git-88af3ceb2009a2d735ff3ae90abd5ae0b84bb6c0.tar.gz
Merge mysql.com:/Users/kent/mysql/bk/mysql-4.0
into mysql.com:/Users/kent/mysql/bk/mysql-4.1
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am19
1 files changed, 17 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 96f3561e31c..59a977a2633 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -97,7 +97,22 @@ tags:
support-files/build-tags
.PHONY: init-db bin-dist
-# Test installation
+# Test installation. Ports are configurable from the environment.
+
+MYSQL_TEST_MANAGER_PORT = 9305
+MYSQL_TEST_MASTER_PORT = 9306
+MYSQL_TEST_SLAVE_PORT = 9308
+MYSQL_TEST_NDB_PORT = 9350
test:
- cd mysql-test; perl mysql-test-run.pl && perl mysql-test-run.pl --ps-protocol
+ cd mysql-test ; \
+ ./mysql-test-run.pl \
+ --manager-port=$(MYSQL_TEST_MANAGER_PORT) \
+ --master_port=$(MYSQL_TEST_MASTER_PORT) \
+ --slave_port=$(MYSQL_TEST_SLAVE_PORT) \
+ --ndbcluster_port=$(MYSQL_TEST_NDB_PORT) && \
+ ./mysql-test-run.pl --ps-protocol \
+ --manager-port=$(MYSQL_TEST_MANAGER_PORT) \
+ --master_port=$(MYSQL_TEST_MASTER_PORT) \
+ --slave_port=$(MYSQL_TEST_SLAVE_PORT) \
+ --ndbcluster_port=$(MYSQL_TEST_NDB_PORT)