summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorunknown <kent@mysql.com>2005-08-28 19:46:56 +0200
committerunknown <kent@mysql.com>2005-08-28 19:46:56 +0200
commitf658a7a7c3616c5edec3b1e0a79427ca98b20fdb (patch)
tree5dc6119d75aec556ef08efab31b1a790dcbf9c01 /Makefile.am
parent97dbe8dbe31d8bc8625c19a0a141a7fc910c37db (diff)
downloadmariadb-git-f658a7a7c3616c5edec3b1e0a79427ca98b20fdb.tar.gz
Makefile.am:
Make ports configurable from environment for test Makefile.am: Make ports configurable from environment for test
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 10 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 1609b5a1da1..be2d34f8db8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -85,8 +85,15 @@ tags:
support-files/build-tags
.PHONY: init-db bin-dist
-# Test installation
+# Test installation. Ports are configurable from the environment.
-test:
- cd mysql-test ; ./mysql-test-run
+MYSQL_TEST_MANAGER_PORT = 9305
+MYSQL_TEST_MASTER_PORT = 9306
+MYSQL_TEST_SLAVE_PORT = 9308
+test:
+ cd mysql-test ; \
+ ./mysql-test-run \
+ --manager-port=$(MYSQL_TEST_MANAGER_PORT) \
+ --master_port=$(MYSQL_TEST_MASTER_PORT) \
+ --slave_port=$(MYSQL_TEST_SLAVE_PORT)