summaryrefslogtreecommitdiff
path: root/Docs/Makefile.am
diff options
context:
space:
mode:
authorlenz@mysql.com <>2004-08-05 01:54:04 +0200
committerlenz@mysql.com <>2004-08-05 01:54:04 +0200
commite5cb60dcaad6a17a6368321e7a02ed9299c8c5ac (patch)
tree31c74b5bf320b1e071239c7949bf6f30bee8e600 /Docs/Makefile.am
parentaf88ae0aa6e16fb769fa267dbb9e605be7a4e3f9 (diff)
downloadmariadb-git-e5cb60dcaad6a17a6368321e7a02ed9299c8c5ac.tar.gz
- applied the required changes to create the FOSS License exception
file "EXCEPTIONS" and include it in the source and binary distributions
Diffstat (limited to 'Docs/Makefile.am')
-rw-r--r--Docs/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/Docs/Makefile.am b/Docs/Makefile.am
index 9a77202a91b..fe203a4d0bf 100644
--- a/Docs/Makefile.am
+++ b/Docs/Makefile.am
@@ -26,7 +26,7 @@ EXTRA_DIST = $(noinst_SCRIPTS) $(BUILT_SOURCES) mysqld_error.txt \
all: $(targets) txt_files
-txt_files: ../INSTALL-SOURCE ../COPYING \
+txt_files: ../INSTALL-SOURCE ../COPYING ../EXCEPTIONS \
INSTALL-BINARY ../support-files/MacOSX/ReadMe.txt
CLEAN_FILES: $(BUILD_SOURCES)
@@ -202,7 +202,10 @@ INSTALL-BINARY: mysql.info $(GT)
perl -w $(GT) mysql.info "Installing binary" "Installing source" > $@
../COPYING: mysql.info $(GT)
- perl -w $(GT) mysql.info "GPL license" "Function Index" > $@
+ perl -w $(GT) mysql.info "GPL license" "MySQL FOSS License Exception" > $@
+
+../EXCEPTIONS: mysql.info $(GT)
+ perl -w $(GT) mysql.info "MySQL FOSS License Exception" "Function Index" > $@
../support-files/MacOSX/ReadMe.txt: mysql.info $(GT)
perl -w $(GT) mysql.info "Mac OS X installation" "NetWare installation" > $@