summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorVladislav Vaintroub <vvaintroub@mysql.com>2009-12-17 14:41:50 +0100
committerVladislav Vaintroub <vvaintroub@mysql.com>2009-12-17 14:41:50 +0100
commiteb3c44030bf398ddaf033be1a3b1b163faa9bce3 (patch)
treeb9698e003a32f65faf28d6032f377916cf93b648 /CMakeLists.txt
parent07bfd2617db894f9a6a4ad5998941d3517974bb7 (diff)
downloadmariadb-git-eb3c44030bf398ddaf033be1a3b1b163faa9bce3.tar.gz
Replace ADD_EXECUTABLE with MYSQL_ADD_EXECUTABLE for binaries that are installed.
MYSQL_ADD_EXECUTABLE will instructs CPack where to install the exe. On Windows, it also adds version resource and if -DSIGNCODE was given, will sign the exe in packaging step.
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 51a50f682ba..81681dddb6e 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -19,6 +19,7 @@ if("${CMAKE_MAJOR_VERSION}.${CMAKE_MINOR_VERSION}" GREATER 2.6)
CMAKE_POLICY(VERSION 2.8)
endif()
+SET(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${CMAKE_SOURCE_DIR}/cmake)
# First, decide about build type (debug or release)
# If custom compiler flags are set or cmake is invoked with -DCMAKE_BUILD_TYPE,
@@ -70,6 +71,7 @@ INCLUDE(cmake/libutils.cmake)
INCLUDE(cmake/dtrace.cmake)
INCLUDE(cmake/plugin.cmake)
INCLUDE(cmake/install_macros.cmake)
+INCLUDE(mysql_add_executable)
# Handle options
OPTION(DISABLE_SHARED