summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBo Thorsen <bo@askmonty.org>2010-06-28 15:31:47 +0200
committerBo Thorsen <bo@askmonty.org>2010-06-28 15:31:47 +0200
commit1c0f9f9d7eb2c9985fb3948ee87982673a8c8a80 (patch)
treed7d0a9150eb9db686554119f2943e22c5a49dfd1 /CMakeLists.txt
parentc77f7c3010be4384d2ba8682cb30b5c818d103ac (diff)
downloadmariadb-git-1c0f9f9d7eb2c9985fb3948ee87982673a8c8a80.tar.gz
Fix a loop and install more script files. Renames the perlscripts component to scripts, since it now also has sql scripts.
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt12
1 files changed, 6 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c1c3fe2722f..425039ea062 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -355,11 +355,11 @@ SET(CPACK_COMPONENT_HEADERS_DESCRIPTION "Header files for development on MariaDB
SET(CPACK_COMPONENT_HEADERS_DEPENDS runtime)
SET(CPACK_COMPONENT_HEADERS_GROUP "Development")
SET(CPACK_COMPONENT_HEADERS_INSTALL_TYPES Development)
-SET(CPACK_COMPONENT_PERLSCRIPTS_DISPLAY_NAME "Server perl scripts")
-SET(CPACK_COMPONENT_PERLSCRIPTS_DESCRIPTION "Scripts to controll and modify the server. You need a perl installation for these to work.")
-SET(CPACK_COMPONENT_PERLSCRIPTS_DEPENDS runtime)
-SET(CPACK_COMPONENT_PERLSCRIPTS_GROUP "Server")
-SET(CPACK_COMPONENT_PERLSCRIPTS_INSTALL_TYPES Normal Development)
+SET(CPACK_COMPONENT_SCRIPTS_DISPLAY_NAME "Server scripts")
+SET(CPACK_COMPONENT_SCRIPTS_DESCRIPTION "SQL and Perl scripts to control and modify the server. You need a perl installation for some of these to work.")
+SET(CPACK_COMPONENT_SCRIPTS_DEPENDS runtime)
+SET(CPACK_COMPONENT_SCRIPTS_GROUP "Server")
+SET(CPACK_COMPONENT_SCRIPTS_INSTALL_TYPES Normal Development)
# TODO: Add debug files
# TODO: Add embedded server files
# TODO: Add test files
@@ -402,7 +402,7 @@ FOREACH(ERRMSGFILE ${share_dirs})
FILE(RELATIVE_PATH DIRNAME ${PROJECT_SOURCE_DIR}/sql/share ${ERRMSGFILE})
STRING(REPLACE "/errmsg.sys" "" DIRNAME ${DIRNAME})
INSTALL(FILES ${ERRMSGFILE} DESTINATION share/${DIRNAME} COMPONENT runtime)
-ENDFOREACH(SUBDIR ${share_dirs})
+ENDFOREACH(ERRMSGFILE ${share_dirs})
INCLUDE(InstallRequiredSystemLibraries)