summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorVladislav Vaintroub <vvaintroub@mysql.com>2010-02-16 16:06:57 +0100
committerVladislav Vaintroub <vvaintroub@mysql.com>2010-02-16 16:06:57 +0100
commit7e01172ce3737d5ab621c3f4ffd06af00b416df8 (patch)
tree7c36e5a5a382639f885c367f980bd3ff5ca59854 /CMakeLists.txt
parent80536ba7bd8d6be9f5ddd1de9e025270a322a70e (diff)
downloadmariadb-git-7e01172ce3737d5ab621c3f4ffd06af00b416df8.tar.gz
Fix a couple fo things replated to MSI
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt8
1 files changed, 5 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f1185e65028..814d2ebaf7c 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -264,14 +264,16 @@ CONFIGURE_FILE(${CMAKE_SOURCE_DIR}/sql/sql_builtin.cc.in
INSTALL(FILES EXCEPTIONS-CLIENT DESTINATION ${INSTALL_DOCREADMEDIR} COMPONENT
Development)
-INSTALL(FILES COPYING README DESTINATION ${INSTALL_DOCREADMEDIR})
+
+INSTALL(FILES COPYING DESTINATION ${INSTALL_DOCREADMEDIR} COMPONENT Readme OPTIONAL)
+INSTALL(FILES README DESTINATION ${INSTALL_DOCREADMEDIR} COMPONENT Readme)
IF(UNIX)
- INSTALL(FILES Docs/INSTALL-BINARY DESTINATION ${INSTALL_DOCREADMEDIR})
+ INSTALL(FILES Docs/INSTALL-BINARY DESTINATION ${INSTALL_DOCREADMEDIR} COMPONENT Documentation)
ENDIF()
# MYSQL_DOCS_LOCATON is used in "make dist", points to the documentation directory
SET(MYSQL_DOCS_LOCATION "" CACHE PATH "Location from where documentation is copied")
MARK_AS_ADVANCED(MYSQL_DOCS_LOCATION)
-INSTALL(DIRECTORY Docs/ DESTINATION ${INSTALL_DOCDIR})
+INSTALL(DIRECTORY Docs/ DESTINATION ${INSTALL_DOCDIR} COMPONENT Documentation)
# Packaging
IF(WIN32)
SET(CPACK_GENERATOR "ZIP")