summaryrefslogtreecommitdiff
path: root/tools/Makefile.am
diff options
context:
space:
mode:
authorPeter Hutterer <peter.hutterer@who-t.net>2014-03-18 10:49:22 +1000
committerPeter Hutterer <peter.hutterer@who-t.net>2014-03-20 07:31:06 +1000
commit47c983478ab1094c02a5b3251cf5564153730645 (patch)
tree2331667da3804838e4f664303da8ce7ebe30c5b5 /tools/Makefile.am
parentbc479f8804762987403d8fc2a65dfaf5fbee342d (diff)
downloadxf86-input-wacom-47c983478ab1094c02a5b3251cf5564153730645.tar.gz
tools: add an inputattach-like tool
Does more or less the same thing as inputattach, but tries to be a bit smarter about the baud rate depending on the tablet model. And re-tries if the baud rate is wrong. Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net> Acked-by: Jason Gerecke <killertofu@gmail.com>
Diffstat (limited to 'tools/Makefile.am')
-rw-r--r--tools/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am
index 5eba0a6..a49380b 100644
--- a/tools/Makefile.am
+++ b/tools/Makefile.am
@@ -18,7 +18,7 @@
# IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN
# CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
-bin_PROGRAMS = xsetwacom isdv4-serial-debugger
+bin_PROGRAMS = xsetwacom isdv4-serial-debugger isdv4-serial-inputattach
AM_CPPFLAGS = -I$(top_srcdir)/include
AM_CFLAGS = $(XORG_CFLAGS) $(X11_CFLAGS)
@@ -27,6 +27,9 @@ AM_LDFLAGS = $(X11_LIBS)
shared_sources = tools-shared.h tools-shared.c
isdv4_serial_debugger_SOURCES = isdv4-serial-debugger.c $(shared_sources)
+isdv4_serial_inputattach_SOURCES = isdv4-serial-inputattach.c $(shared_sources)
+isdv4_serial_inputattach_CFLAGS = $(UDEV_CFLAGS)
+isdv4_serial_inputattach_LDADD = $(UDEV_LIBS)
if UNITTESTS