summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJason Gerecke <killertofu@gmail.com>2014-04-10 15:24:15 -0700
committerJason Gerecke <killertofu@gmail.com>2014-05-07 13:58:40 -0700
commit34ca9ab25d682335021097713650782e82f6dc73 (patch)
tree88ea2d042fdafece999d23365b9ba55db5c026d4 /configure.ac
parentbecbee2f2b94b969f0bc2172a44c7bfe0804774e (diff)
downloadxf86-input-wacom-34ca9ab25d682335021097713650782e82f6dc73.tar.gz
Update configure help to indicate that debugging is enabled by default
Running `./configure --help` indicates that debugging is disabled by default, but this is not the case. Change the documentation to state that it is enabled, and show the "--disable-debugging" option to make it clear.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 4 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 5eae74d..b1a89bd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -77,9 +77,10 @@ AC_SUBST([DRIVER_NAME])
# -----------------------------------------------------------------------------
# Define a configure option for code debugging
AC_ARG_ENABLE(debug,
- AS_HELP_STRING([--enable-debug],
- [Enable debugging (default: disabled)]),
- [DEBUGGING=$enableval], [DEBUGGING=yes])
+ AS_HELP_STRING([--disable-debug],
+ [Disable debugging (default: enabled)]),
+ [DEBUGGING=$enableval],
+ [DEBUGGING=yes])
# Define the C preprocessor macro DEBUG in config.h
if test "x$DEBUGGING" = xyes; then