summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGaetan Nadon <memsize@videotron.ca>2010-12-02 17:11:41 -0500
committerPeter Hutterer <peter.hutterer@who-t.net>2010-12-03 11:30:19 +1000
commit6a1372676f4daea36028fdcffd32d9090d979cc6 (patch)
treeea285f5bb2d414d5900233661824c2d31ea3b14f /configure.ac
parenta474d4069f8622b5b158152c16c02118f2a4d415 (diff)
downloadxf86-input-wacom-6a1372676f4daea36028fdcffd32d9090d979cc6.tar.gz
config: missing randr extension not detected
Problem introduced in commit 8f1dd625e00c182ec1b6a92b277214d1b8f88986. # Store the list of server defined optional extensions in REQUIRED_MODULES XORG_DRIVER_CHECK_EXT(RANDR, randrproto) The role of the driver check macro is to supply the name of optional extension to the PKG_CHECK_MODULES through the REQUIRED_MODULES variable. By reversing the order of the statements the variable is empty. The real fix would be to have 2 PKG_CHECK_MODULES statements, one to ensure the server is present at the correct level and one to check the dependencies. This won't be necessary as the RANDR extension is not optional, it is always present. It can simply go next to the others. All the xorg drivers have this flaw. This undetected missing randr ext problem only happens with server 1.8 or prior, as a new Requires.private statement has been added to server 1.9. Signed-off-by: Gaetan Nadon <memsize@videotron.ca> Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 1 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index ede9a7f..0bb2482 100644
--- a/configure.ac
+++ b/configure.ac
@@ -48,10 +48,7 @@ XORG_DEFAULT_OPTIONS
AC_CHECK_LIB([m], [rint])
# Obtain compiler/linker options from server and required extensions
-PKG_CHECK_MODULES(XORG, [xorg-server >= 1.7.0] xproto xext kbproto inputproto $REQUIRED_MODULES)
-
-# Store the list of server defined optional extensions in REQUIRED_MODULES
-XORG_DRIVER_CHECK_EXT(RANDR, randrproto)
+PKG_CHECK_MODULES(XORG, [xorg-server >= 1.7.0] xproto xext kbproto inputproto randrproto)
# Obtain compiler/linker options for the xsetwacom tool
PKG_CHECK_MODULES(X11, x11 xi xrandr)