summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDaniel Veillard <veillard@src.gnome.org>2002-09-23 08:16:17 +0000
committerDaniel Veillard <veillard@src.gnome.org>2002-09-23 08:16:17 +0000
commit23437cdf6ca08fbc3f6368411f5fa20f63109aca (patch)
tree11a47aae86c627f50b31ad055eddbcc7efbdc0ee /Makefile.am
parent8b0a0807cdd3f407d6d86d256188655fc135cf9f (diff)
downloadlibxslt-23437cdf6ca08fbc3f6368411f5fa20f63109aca.tar.gz
set-up DIST_SUBDIRS to avoid the same problem Jacob reported for libxml2
* Makefile.am: set-up DIST_SUBDIRS to avoid the same problem Jacob reported for libxml2 Daniel
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 5 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index da9340ce..215cde22 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -6,7 +6,7 @@ SUBDIRS = \
libexslt \
xsltproc \
doc \
- python \
+ @PYTHON_SUBDIR@ \
tests
else
SUBDIRS = \
@@ -14,10 +14,12 @@ SUBDIRS = \
libexslt \
xsltproc \
doc \
- python \
+ @PYTHON_SUBDIR@ \
tests
endif
+DIST_SUBDIRS = libxslt libexslt xsltproc python doc tests breakpoint
+
confexecdir=$(libdir)
confexec_DATA = xsltConf.sh
@@ -51,7 +53,7 @@ dummy:
tests: dummy
@(cd tests ; $(MAKE) tests)
- @(cd python ; $(MAKE) tests)
+ @(if [ "@PYTHON_SUBDIR@" != "" ] ; then cd python ; $(MAKE) tests ; fi)
valgrind:
@echo '## Running the regression tests under Valgrind'