summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorRoumen Petrov <bugtrack@roumenpetrov.info>2010-03-11 14:49:13 +0100
committerDaniel Veillard <veillard@redhat.com>2010-03-11 14:49:13 +0100
commitf39adc2516cba3532856e2bf2d71d09e6617a34b (patch)
treeebb6af6179b2ffd8144d31e1f5bc72cde98bdaf6 /configure.in
parent1e60fbcb6ff7a054de9dc6bc05aaf01172ad3a6f (diff)
downloadlibxml2-f39adc2516cba3532856e2bf2d71d09e6617a34b.tar.gz
Fix build failure on Sparc solaris
Tries to find the right ld options needed to pass a linker script.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 8 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 5c9ffbdf..fbfebf62 100644
--- a/configure.in
+++ b/configure.in
@@ -73,10 +73,14 @@ dnl if the system support linker version scripts for symbol versioning
dnl then add it
dnl
VERSION_SCRIPT_FLAGS=
-$(/usr/bin/ld --help 2>&1 | grep -- --version-script >/dev/null) && \
- VERSION_SCRIPT_FLAGS=-Wl,--version-script=
-test "`uname`" == "SunOS" && \
- VERSION_SCRIPT_FLAGS="-Wl,-M -Wl,"
+# lt_cv_prog_gnu_ld is from libtool 2.+
+if test "$lt_cv_prog_gnu_ld" = yes; then
+ VERSION_SCRIPT_FLAGS=-Wl,--version-script=
+else
+ case $host in
+ *-*-sunos*) VERSION_SCRIPT_FLAGS="-Wl,-M -Wl,";;
+ esac
+fi
AC_SUBST(VERSION_SCRIPT_FLAGS)
AM_CONDITIONAL([USE_VERSION_SCRIPT], [test -n "$VERSION_SCRIPT_FLAGS"])