summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorVincent Untz <vuntz@gnome.org>2011-06-14 15:08:55 +0200
committerVincent Untz <vuntz@gnome.org>2011-06-14 15:08:55 +0200
commite4200d706a7c11fc6e2b34fc406feb837d230875 (patch)
treeac6a9c34142aba5c5cb66793dcff84f7a8c7cd9d /configure.ac
parent6aec01569d3ecafbfc38edb91e79808b1a4b1b1a (diff)
downloadlibwnck-e4200d706a7c11fc6e2b34fc406feb837d230875.tar.gz
build: Modernize build system a bit
Use the tar-ustar option for AM_INIT_AUTOMAKE for better tarballs. Do not use AM_MAINTAINER_MODE as it is not recommended by automake developers. Stop using GNOME_COMMON_INIT as it is deprecated. Use LT_PREREQ & LT_INIT for libtool checks. Require intltool 0.40.6 to avoid various bugs. Do not use AC_ISC_POSIX, AC_HEADER_STDC as they shouldn't be needed on modern systems. Drop manual check for additional compiler flags.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac36
1 files changed, 6 insertions, 30 deletions
diff --git a/configure.ac b/configure.ac
index 5f3c49e..ccb8e38 100644
--- a/configure.ac
+++ b/configure.ac
@@ -11,12 +11,10 @@ AC_INIT([libwnck], [wnck_version],
AM_CONFIG_HEADER(config.h)
-AM_INIT_AUTOMAKE([1.9 no-dist-gzip dist-bzip2])
+AM_INIT_AUTOMAKE([1.9 no-dist-gzip dist-bzip2 tar-ustar])
m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
AC_CONFIG_MACRO_DIR([m4])
-AM_MAINTAINER_MODE
-GNOME_COMMON_INIT
GNOME_MAINTAINER_MODE_DEFINES
dnl libtool versioning for libwnck
@@ -44,36 +42,14 @@ AC_SUBST(WNCK_MAJOR_VERSION)
AC_SUBST(WNCK_MINOR_VERSION)
AC_SUBST(WNCK_MICRO_VERSION)
-IT_PROG_INTLTOOL([0.40.0])
+LT_PREREQ([2.2.6])
+LT_INIT([dlopen disable-static])
+
+IT_PROG_INTLTOOL([0.40.6])
AC_PROG_CC
-AC_ISC_POSIX
-AC_HEADER_STDC
-AC_LIBTOOL_WIN32_DLL
-AM_PROG_LIBTOOL
-
-changequote(,)dnl
-if test "x$GCC" = "xyes"; then
- case " $CFLAGS " in
- *[\ \ ]-Wall[\ \ ]*) ;;
- *) CFLAGS="$CFLAGS -Wall" ;;
- esac
-
- if test "x$enable_ansi" = "xyes"; then
- case " $CFLAGS " in
- *[\ \ ]-ansi[\ \ ]*) ;;
- *) CFLAGS="$CFLAGS -ansi" ;;
- esac
-
- case " $CFLAGS " in
- *[\ \ ]-pedantic[\ \ ]*) ;;
- *) CFLAGS="$CFLAGS -pedantic" ;;
- esac
- fi
-fi
-changequote([,])dnl
-GNOME_COMPILE_WARNINGS(maximum)
+GNOME_COMPILE_WARNINGS([maximum])
AC_ARG_ENABLE(deprecation_flags,
[AC_HELP_STRING([--enable-deprecation-flags],