summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorJames Zern <jzern@google.com>2012-04-23 18:46:12 -0700
committerJames Zern <jzern@google.com>2012-07-11 14:25:41 -0700
commite41a7596156445ce442da79ea1c35a4ddcb3ac34 (patch)
tree5a1c5861ce88fa32f0f6b4b46abfc25c4a4d86a0 /src/Makefile.am
parent63db87dd2a3b261f96d158d019e0cf376a836c96 (diff)
downloadlibwebp-e41a7596156445ce442da79ea1c35a4ddcb3ac34.tar.gz
build: remove libwebpmux from default targets/config
the extended file format is still under development and related libs/binaries are not fit for release configure: --enable/disable-libwebpmux; default is disabled. makefile.unix: src/mux/libwebpmux.a and examples/webpmux must be explicitly specified Makefile.vc: $(DIRLIB)\libwebpmux.lib and $(DIRBIN)\webpmux.exe must be explicitly specified Change-Id: I8246746b256010dd2a2e4de58291222d7eaf0457
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 42ab37dc..1da5ae9a 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,4 +1,7 @@
-SUBDIRS = dec enc dsp utils mux
+SUBDIRS = dec enc dsp utils
+if WANT_MUX
+ SUBDIRS += mux
+endif
AM_CPPFLAGS = -I$(top_srcdir)/src
lib_LTLIBRARIES = libwebp.la