summaryrefslogtreecommitdiff
path: root/i965_drv_video/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'i965_drv_video/Makefile.am')
-rw-r--r--i965_drv_video/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/i965_drv_video/Makefile.am b/i965_drv_video/Makefile.am
index c106aae..405489b 100644
--- a/i965_drv_video/Makefile.am
+++ b/i965_drv_video/Makefile.am
@@ -23,7 +23,6 @@
SUBDIRS = shaders
INCLUDES = \
- -Wall \
-I$(top_srcdir) \
-I$(top_srcdir)/va \
-I$(top_srcdir)/va/x11 \
@@ -31,6 +30,11 @@ INCLUDES = \
$(DRM_CFLAGS) \
$(NULL)
+driver_cflags = \
+ -Wall \
+ -fvisibility=hidden \
+ $(NULL)
+
driver_ldflags = \
-module -avoid-version \
-no-undefined \
@@ -88,6 +92,7 @@ source_h = \
i965_drv_video_la_LTLIBRARIES = i965_drv_video.la
i965_drv_video_ladir = $(LIBVA_DRIVERS_PATH)
+i965_drv_video_la_CFLAGS = $(driver_cflags)
i965_drv_video_la_LDFLAGS = $(driver_ldflags)
i965_drv_video_la_LIBADD = $(top_builddir)/va/libva-x11.la -lpthread
i965_drv_video_la_SOURCES = $(source_c)