summaryrefslogtreecommitdiff
path: root/libusb/Makefile.am
diff options
context:
space:
mode:
authorDaniel Drake <dsd@gentoo.org>2008-04-17 18:24:54 +0100
committerDaniel Drake <dsd@gentoo.org>2008-04-17 18:33:41 +0100
commitf5a33e08ec0da51ccb5e95a5adec50c5211a9bf5 (patch)
tree16a7007381507f3b1e0ebdd96b8aadd2f010c138 /libusb/Makefile.am
parent85e1994123545125ce0653415d122f9790f8d041 (diff)
downloadlibusb-f5a33e08ec0da51ccb5e95a5adec50c5211a9bf5.tar.gz
flying_transfers mutex protection
This marks the beginnings of thread safety
Diffstat (limited to 'libusb/Makefile.am')
-rw-r--r--libusb/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/libusb/Makefile.am b/libusb/Makefile.am
index fb5d033..97743fa 100644
--- a/libusb/Makefile.am
+++ b/libusb/Makefile.am
@@ -8,7 +8,7 @@ if OS_LINUX
OS_SRC = $(LINUX_USBFS_SRC)
endif
-libusb_1_0_la_CFLAGS = -fvisibility=hidden $(AM_CFLAGS)
+libusb_1_0_la_CFLAGS = -fvisibility=hidden $(AM_CFLAGS) -pthread
libusb_1_0_la_SOURCES = libusbi.h core.c descriptor.c io.c sync.c $(OS_SRC)
libusb_1_0_la_LIBADD = -lrt