summaryrefslogtreecommitdiff
path: root/libusb/Makefile.am
diff options
context:
space:
mode:
authorDaniel Drake <dsd@gentoo.org>2008-01-30 13:19:10 +0000
committerDaniel Drake <dsd@gentoo.org>2008-01-30 13:19:10 +0000
commit637a8d7ff8a11a23588925d9d3003a609bda8075 (patch)
tree1c008df19c1c2a0374e436b07288db0533bd302e /libusb/Makefile.am
parent8c56abe2e13ed4dd8c15737c21be7b6b1e5cf2ac (diff)
downloadlibusb-637a8d7ff8a11a23588925d9d3003a609bda8075.tar.gz
Remove timers and signalfd
Instead of timers, add a mechanism for informing the parent app when the next timeout is due to happen, so that it can call us at that time. As we no longer use signals, signalfd has also been removed.
Diffstat (limited to 'libusb/Makefile.am')
-rw-r--r--libusb/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/libusb/Makefile.am b/libusb/Makefile.am
index d921468..702e702 100644
--- a/libusb/Makefile.am
+++ b/libusb/Makefile.am
@@ -1,7 +1,7 @@
lib_LTLIBRARIES = libusb-1.0.la
libusb_1_0_la_CFLAGS = -fvisibility=hidden $(AM_CFLAGS)
-libusb_1_0_la_SOURCES = signalfd.h libusbi.h usbfs.h core.c descriptor.c io.c
+libusb_1_0_la_SOURCES = libusbi.h usbfs.h core.c descriptor.c io.c
libusb_1_0_la_LIBADD = -lrt
pkginclude_HEADERS = libusb.h