summaryrefslogtreecommitdiff
path: root/libusb/Makefile.am
diff options
context:
space:
mode:
authorPete Batard <pbatard@gmail.com>2010-01-14 00:30:20 +0000
committerPete Batard <pbatard@gmail.com>2010-01-14 00:30:20 +0000
commitdf329ef40549e040d3638e18232ef41f89d47764 (patch)
treee767269410d10ed5e68e59912b73f90d5ed7b46a /libusb/Makefile.am
parentd5d7f721bb06a3c2f513826218c89fcbb50af8fd (diff)
downloadlibusb-df329ef40549e040d3638e18232ef41f89d47764.tar.gz
mirror libusb-winusb git branch from 2009.12.03 part 2 - core files
Diffstat (limited to 'libusb/Makefile.am')
-rw-r--r--libusb/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/libusb/Makefile.am b/libusb/Makefile.am
index a2be46c..cf777bc 100644
--- a/libusb/Makefile.am
+++ b/libusb/Makefile.am
@@ -2,8 +2,9 @@ lib_LTLIBRARIES = libusb-1.0.la
LINUX_USBFS_SRC = os/linux_usbfs.h os/linux_usbfs.c
DARWIN_USB_SRC = os/darwin_usb.h os/darwin_usb.c
+WINDOWS_USB_SRC = os/windows_usb.h os/windows_usb.c os/windows_compat.h os/windows_compat.c
-EXTRA_DIST = $(LINUX_USBFS_SRC) $(DARWIN_USB_SRC)
+EXTRA_DIST = $(LINUX_USBFS_SRC) $(DARWIN_USB_SRC) $(WINDOWS_USB_SRC)
if OS_LINUX
OS_SRC = $(LINUX_USBFS_SRC)
@@ -14,6 +15,10 @@ OS_SRC = $(DARWIN_USB_SRC)
AM_CFLAGS_EXT = -no-cpp-precomp
endif
+if OS_WINDOWS
+OS_SRC = $(WINDOWS_USB_SRC)
+endif
+
libusb_1_0_la_CFLAGS = $(VISIBILITY_CFLAGS) $(AM_CFLAGS) -pthread
libusb_1_0_la_SOURCES = libusbi.h core.c descriptor.c io.c sync.c $(OS_SRC)