summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLudovic Rousseau <ludovic.rousseau@gmail.com>2012-06-01 11:30:00 +0200
committerPete Batard <pete@akeo.ie>2012-06-04 01:19:25 +0100
commitc9d41fe5f0324d969f758f42843e1fd05859f438 (patch)
treeb7ec8ed6329b07669a634d432877c12ee5b17db1 /configure.ac
parente6546429380750d5b6bb2617ce3637d73e822ac8 (diff)
downloadlibusb-c9d41fe5f0324d969f758f42843e1fd05859f438.tar.gz
Autotools: Apply autoupdate 2.68 recommendations
* Not applied: AC_PREREQ([2.68]) as this doesn't seem necessary and 2.68 was released less than 2 years ago.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 792035f..d91d042 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8,14 +8,14 @@ m4_define([LU_DEFINE_VERSION_RC_ATOM],
[^#define\s*$1\s*"\(-rc[0-9]*\)".*], [\1]))])
dnl The m4_bregexp() returns (only) the numbers following the #define named
dnl in the first macro parameter. m4_define() then defines the name for use
-dnl in AC_INIT().
+dnl in AC_INIT.
LU_DEFINE_VERSION_ATOM([LIBUSB_MAJOR])
LU_DEFINE_VERSION_ATOM([LIBUSB_MINOR])
LU_DEFINE_VERSION_ATOM([LIBUSB_MICRO])
LU_DEFINE_VERSION_RC_ATOM([LIBUSB_RC])
-AC_INIT([libusbx], LIBUSB_MAJOR[.]LIBUSB_MINOR[.]LIBUSB_MICRO[]LIBUSB_RC, [libusbx-devel@lists.sourceforge.net], [libusbx], [http://www.libusbx.org/])
+AC_INIT([libusbx],[LIBUSB_MAJOR.LIBUSB_MINOR.LIBUSB_MICROLIBUSB_RC],[libusbx-devel@lists.sourceforge.net],[libusbx],[http://www.libusbx.org/])
# Library versioning
# These numbers should be tweaked on every release. Read carefully:
@@ -31,12 +31,12 @@ AM_MAINTAINER_MODE
AC_CONFIG_SRCDIR([libusb/core.c])
AC_CONFIG_MACRO_DIR([m4])
-AM_CONFIG_HEADER([config.h])
+AC_CONFIG_HEADERS([config.h])
m4_ifdef([AM_SILENT_RULES],[AM_SILENT_RULES([yes])])
AC_PREREQ([2.50])
AC_PROG_CC
-AC_PROG_LIBTOOL
+LT_INIT
LT_LANG([Windows Resource])
AC_C_INLINE
AM_PROG_CC_C_O