summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Drake <dan@reactivated.net>2010-07-21 17:49:21 -0600
committerDaniel Drake <dan@reactivated.net>2010-07-22 18:33:37 -0600
commita516fcb99376686d2d0028e5ac69950c57a55b9e (patch)
tree56ff2f820c13e5ce019aa6292fd34776a4ff29f2 /configure.ac
parenta1d831ef82e1700f4ebb9df6ca5cef74be757c08 (diff)
downloadlibusb-a516fcb99376686d2d0028e5ac69950c57a55b9e.tar.gz
Only compile dpfp examples when sigaction is available
It's not available on MinGW.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0c8eb76..36f364c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -127,6 +127,10 @@ AC_COMPILE_IFELSE(AC_LANG_PROGRAM([]),
nopointersign_cflags="-Wno-pointer-sign", nopointersign_cflags="")
CFLAGS="$saved_cflags"
+# sigaction not available on MinGW
+AC_CHECK_FUNC([sigaction], [have_sigaction=yes], [have_sigaction=no])
+AM_CONDITIONAL([HAVE_SIGACTION], [test "x$have_sigaction" = "xyes"])
+
# headers not available on all platforms but required on others
AC_CHECK_HEADERS([sys/time.h])