summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPeter Stuge <peter@stuge.se>2010-10-30 22:13:05 +0200
committerPeter Stuge <peter@stuge.se>2011-06-13 22:01:42 +0200
commit16cf11a1213272afd616598fa3aba0941e66ec3c (patch)
treedac43072dae6abab75769e4523e59a7b1d0ebd59 /configure.ac
parenta120747d561929682cd0276ea4c13fb22fad8554 (diff)
downloadlibusb-16cf11a1213272afd616598fa3aba0941e66ec3c.tar.gz
configure.ac: Do not use -pthread on Darwin
It's not needed because Darwin has POSIX Threads in libc. Fixes #96.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 1 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index c6515ad..febe0e9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -59,8 +59,7 @@ case $host in
AC_MSG_RESULT([Darwin/MacOS X])
backend="darwin"
threads="posix"
- THREAD_CFLAGS="-pthread"
- PC_LIBS_PRIVATE="-Wl,-framework,IOKit -Wl,-framework,CoreFoundation -Wl,-prebind -no-undefined -pthread"
+ PC_LIBS_PRIVATE="-Wl,-framework,IOKit -Wl,-framework,CoreFoundation -Wl,-prebind -no-undefined"
AM_LDFLAGS=${PC_LIBS_PRIVATE}
AC_CHECK_HEADERS([poll.h])
AC_CHECK_TYPE([nfds_t],