summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPete Batard <pete@akeo.ie>2012-06-07 11:55:30 +0100
committerPete Batard <pete@akeo.ie>2012-06-07 11:55:30 +0100
commitff3259b440b3fa55a48cfb6233341c9ff664894a (patch)
tree30ad665f9f572d9c4c847d05b47d706191969df6 /configure.ac
parent9497ad5711501b6281cc58c1637576be7ceffccd (diff)
downloadlibusb-ff3259b440b3fa55a48cfb6233341c9ff664894a.tar.gz
Windows: Fix possible crash when using longjmp and gcc 4.6
* With gcc-4.6 the option -fomit-frame-pointer is turned on per default even for the win32 target. This results in segfaults for any application using setjmp/longjmp and MSVCRT.dll on WinXP. See http://gcc.gnu.org/ml/gcc/2011-10/msg00351.html * Issue reported by Lars Kanis
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index b305f68..b29b2bb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -71,6 +71,7 @@ case $host in
AC_MSG_RESULT([Windows])
backend="windows"
threads="windows"
+ AM_CFLAGS="${AM_CFLAGS} -fno-omit-frame-pointer"
;;
*-cygwin*)
AC_MSG_RESULT([Cygwin (using Windows backend)])
@@ -212,7 +213,7 @@ AM_CONDITIONAL([HAVE_SIGACTION], [test "x$have_sigaction" = "xyes"])
AC_CHECK_HEADERS([sys/time.h])
AC_CHECK_FUNCS(gettimeofday)
-AM_CFLAGS="-std=gnu99 -Wall -Wundef -Wunused -Wstrict-prototypes -Werror-implicit-function-declaration $nopointersign_cflags -Wshadow"
+AM_CFLAGS="${AM_CFLAGS} -std=gnu99 -Wall -Wundef -Wunused -Wstrict-prototypes -Werror-implicit-function-declaration $nopointersign_cflags -Wshadow"
AC_SUBST(VISIBILITY_CFLAGS)
AC_SUBST(AM_CFLAGS)