summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Drake <dan@reactivated.net>2010-10-04 18:45:18 +0100
committerDaniel Drake <dan@reactivated.net>2010-10-04 18:45:18 +0100
commitd192c5bd32736fde0080d756de6221287af34891 (patch)
tree61dbc9ae8ba0d2ea077657e1f6adfc7dc03061fb /configure.ac
parente65f69a7ef3de357c867ddaac9598efe407078b6 (diff)
downloadlibusb-d192c5bd32736fde0080d756de6221287af34891.tar.gz
Update libtool version info
With input from various people on the mailing list, update the libtool versioning info and start to update this on every release. The next libusb release will not need a change here. All following ones will.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 11 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 84c361d..38e9ce7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2,11 +2,22 @@ m4_define(LIBUSB_MAJOR, [1])
m4_define(LIBUSB_MINOR, [0])
m4_define(LIBUSB_MICRO, [8])
+# Library versioning
+# These numbers should be tweaked on every release. Read carefully:
+# http://www.gnu.org/software/libtool/manual/html_node/Updating-version-info.html
+# http://sourceware.org/autobook/autobook/autobook_91.html
+lt_current="1"
+lt_revision="0"
+lt_age="1"
+
AC_INIT([libusb], LIBUSB_MAJOR.LIBUSB_MINOR.LIBUSB_MICRO, [libusb-devel@lists.sourceforge.net], [libusb], [http://www.libusb.org/])
AC_SUBST([LIBUSB_VERSION_MAJOR], [LIBUSB_MAJOR])
AC_SUBST([LIBUSB_VERSION_MINOR], [LIBUSB_MINOR])
AC_SUBST([LIBUSB_VERSION_MICRO], [LIBUSB_MICRO])
+AC_SUBST(lt_current)
+AC_SUBST(lt_revision)
+AC_SUBST(lt_age)
AM_INIT_AUTOMAKE
AC_CONFIG_SRCDIR([libusb/core.c])
@@ -78,14 +89,6 @@ AM_CONDITIONAL([OS_DARWIN], [test "x$backend" = "xdarwin"])
AM_CONDITIONAL([OS_WINDOWS], [test "x$backend" = "xwindows"])
AM_CONDITIONAL([THREADS_POSIX], [test "x$threads" = "xposix"])
-# Library versioning
-lt_major="0"
-lt_revision="0"
-lt_age="0"
-AC_SUBST(lt_major)
-AC_SUBST(lt_revision)
-AC_SUBST(lt_age)
-
# timerfd
AC_CHECK_HEADER([sys/timerfd.h], [timerfd_h=1], [timerfd_h=0])
AC_ARG_ENABLE([timerfd],