summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Drake <dsd@gentoo.org>2008-03-13 12:36:56 +0000
committerDaniel Drake <dsd@gentoo.org>2008-03-13 12:46:08 +0000
commitc0c9432d38b22784070dce3a7874c62c31786a27 (patch)
tree825ca9817d3609a0645dbe3f1a1e46aa40dc1ff9 /configure.ac
parentde4c5341d168697baa4c0901c406deb47e78aae7 (diff)
downloadlibusb-c0c9432d38b22784070dce3a7874c62c31786a27.tar.gz
Beginnings of cross-platform abstraction
This also includes a libusb_get_pollfds API change
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 58b4aa2..e8ae187 100644
--- a/configure.ac
+++ b/configure.ac
@@ -10,6 +10,20 @@ AC_C_INLINE
AM_PROG_CC_C_O
AC_DEFINE([_GNU_SOURCE], [], [Use GNU extensions])
+AC_MSG_CHECKING([operating system])
+case $host in
+*-linux*)
+ AC_DEFINE(OS_LINUX, [], [Linux backend])
+ AC_SUBST(OS_LINUX)
+ AC_MSG_RESULT([Linux])
+ backend="linux"
+ ;;
+*)
+ AC_MSG_ERROR([unsupported operating system])
+esac
+
+AM_CONDITIONAL([OS_LINUX], [test "x$backend" == "xlinux"])
+
# Library versioning
lt_major="0"
lt_revision="0"