summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPete Batard <pete@akeo.ie>2012-01-08 00:16:34 +0000
committerPete Batard <pete@akeo.ie>2012-01-08 01:52:40 +0000
commitc7224c9c90c6533a2c568cd6adb3ba3c65b67b39 (patch)
tree1e007cf9dd05e524d5b0eed5804991b0989de2c6 /configure.ac
parente182dbad23570634d6cca971aa6b820898377d4e (diff)
downloadlibusb-c7224c9c90c6533a2c568cd6adb3ba3c65b67b39.tar.gz
[misc] align with master
* up to "Core: Fix #122 warning: no previous prototype for ‘usbi_log_v’" a8e2e7cab278fbfcba91909eaf762cf66da9eda5
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 5 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 6c00b0f..f983e48 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3,16 +3,19 @@ m4_define([LU_VERSION_H], m4_include([libusb/version.h]))
m4_define([LU_DEFINE_VERSION_ATOM],
[m4_define([$1], m4_bregexp(LU_VERSION_H,
[^#define\s*$1\s*\([0-9]*\).*], [\1]))])
+m4_define([LU_DEFINE_VERSION_RC_ATOM],
+ [m4_define([$1], m4_bregexp(LU_VERSION_H,
+ [^#define\s*$1\s*"\(-rc[0-9]*\)".*], [\1]))])
dnl The m4_bregexp() returns (only) the numbers following the #define named
dnl in the first macro parameter. m4_define() then defines the name for use
dnl in AC_INIT().
-
LU_DEFINE_VERSION_ATOM([LIBUSB_MAJOR])
LU_DEFINE_VERSION_ATOM([LIBUSB_MINOR])
LU_DEFINE_VERSION_ATOM([LIBUSB_MICRO])
+LU_DEFINE_VERSION_RC_ATOM([LIBUSB_RC])
-AC_INIT([libusb], LIBUSB_MAJOR[.]LIBUSB_MINOR[.]LIBUSB_MICRO, [libusb-devel@lists.sourceforge.net], [libusb], [http://www.libusb.org/])
+AC_INIT([libusb], LIBUSB_MAJOR[.]LIBUSB_MINOR[.]LIBUSB_MICRO[]LIBUSB_RC, [libusb-devel@lists.sourceforge.net], [libusb], [http://www.libusb.org/])
# Library versioning
# These numbers should be tweaked on every release. Read carefully: