summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Drake <dan@reactivated.net>2010-10-05 11:53:05 +0100
committerDaniel Drake <dan@reactivated.net>2010-10-05 11:53:05 +0100
commit9e172a7829e4a63c79e31ef39aae11fc56633d84 (patch)
tree0ed05d2a01a0f1cff78ae4b8675e0284e2e264f6 /configure.ac
parent55b62476e318f9e761836748ad813deefb51d9c9 (diff)
downloadlibusb-9e172a7829e4a63c79e31ef39aae11fc56633d84.tar.gz
Update libtool version info
With input from various people on the mailing list, update the libtool versioning info and start to update this on every release. The next libusb release will not need a change here. All following ones will.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 11 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 2fa8dc9..7e544f0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -10,6 +10,17 @@ AC_SUBST([LIBUSB_VERSION_MINOR], [LIBUSB_MINOR])
AC_SUBST([LIBUSB_VERSION_MICRO], [LIBUSB_MICRO])
AC_SUBST([LIBUSB_VERSION_NANO], [LIBUSB_NANO])
+# Library versioning
+# These numbers should be tweaked on every release. Read carefully:
+# http://www.gnu.org/software/libtool/manual/html_node/Updating-version-info.html
+# http://sourceware.org/autobook/autobook/autobook_91.html
+lt_current="1"
+lt_revision="0"
+lt_age="1"
+AC_SUBST(lt_current)
+AC_SUBST(lt_revision)
+AC_SUBST(lt_age)
+
AM_INIT_AUTOMAKE
AC_CONFIG_SRCDIR([libusb/core.c])
AC_CONFIG_MACRO_DIR([m4])
@@ -87,14 +98,6 @@ AM_CONDITIONAL([OS_WINDOWS], [test "x$backend" = "xwindows"])
AM_CONDITIONAL([THREADS_POSIX], [test "x$threads" = "xposix"])
AM_CONDITIONAL([CREATE_IMPORT_LIB], [test "x$create_import_lib" = "xyes"])
-# Library versioning
-lt_major="0"
-lt_revision="0"
-lt_age="0"
-AC_SUBST(lt_major)
-AC_SUBST(lt_revision)
-AC_SUBST(lt_age)
-
# timerfd
AC_CHECK_HEADER([sys/timerfd.h], [timerfd_h=1], [timerfd_h=0])
AC_ARG_ENABLE([timerfd],