summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPete Batard <pbatard@gmail.com>2010-08-02 23:13:17 +0100
committerPete Batard <pbatard@gmail.com>2010-08-02 23:13:17 +0100
commit7f4f7bd7538bec65a162e6f19bf4c5e1139e1a5a (patch)
tree430da7451a187f9962aad9069da920bbe982751a /configure.ac
parentc9b0a3b82e3c7771e1f34c134578f9d9bfd71b2e (diff)
downloadlibusb-7f4f7bd7538bec65a162e6f19bf4c5e1139e1a5a.tar.gz
reverted to using a (generated) .def file for DLL exportspbr291
added libusb-1.0.def (plus reference in MS projects) removed LIBUSB_EXP/__declspec(dllexport) from libusb.h removed LIBUSB_DLL_BUILD macros added -Wl,--add-stdcall-alias linker option for MinGW/cygwin for DLL generation added sed script in autogen to update the libusb-1.0.def
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 02cfb14..634a7d7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -57,7 +57,7 @@ case $host in
threads="windows"
LIBS="-lsetupapi -lole32 -ladvapi32"
# -avoid-version to avoid a naming scheme such as libusb-0.dll
- AM_LDFLAGS="-no-undefined -avoid-version"
+ AM_LDFLAGS="-no-undefined -avoid-version -Wl,--add-stdcall-alias"
AM_CFLAGS="-std=c99"
AC_CHECK_TOOL(RC, windres, no)
;;
@@ -70,7 +70,7 @@ case $host in
threads="posix"
LIBS="-lsetupapi -lole32 -ladvapi32"
AM_CFLAGS="-std=c99"
- AM_LDFLAGS="-no-undefined -avoid-version"
+ AM_LDFLAGS="-no-undefined -avoid-version -Wl,--add-stdcall-alias"
AC_CHECK_TOOL(RC, windres, no)
;;
*)