summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPete Batard <pbatard@gmail.com>2010-04-06 21:12:13 +0100
committerPete Batard <pbatard@gmail.com>2010-04-06 21:12:13 +0100
commita7a96927a30094f308ad00bf2af4532e765c05e0 (patch)
tree6fd594ae992c22b8503d4329771b5daeaa982909 /configure.ac
parentadc09459820a35ecaf407adfce4e71835d8e469a (diff)
downloadlibusb-a7a96927a30094f308ad00bf2af4532e765c05e0.tar.gz
added toggable debug logging (core)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 12 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 2aa9ee5..323c54e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -105,11 +105,21 @@ if test "x$log_enabled" != "xno"; then
fi
AC_ARG_ENABLE([debug-log], [AS_HELP_STRING([--enable-debug-log],
- [enable debug logging (default n)])],
+ [enable non-toggable debug logging (default n)])],
[debug_log_enabled=$enableval],
[debug_log_enabled='no'])
+
+AC_ARG_ENABLE([toggable-debug], [AS_HELP_STRING([--enable-toggable-debug],
+ [enable toggable debug logging (default n)])],
+ [toggable_debug=$enableval],
+ [toggable_debug='no'])
+
if test "x$debug_log_enabled" != "xno"; then
- AC_DEFINE([ENABLE_DEBUG_LOGGING], 1, [Debug message logging])
+ AC_DEFINE([ENABLE_DEBUG_LOGGING], 1, [Debug message logging (non toggable)])
+else
+ if test "x$toggable_debug" != "xno"; then
+ AC_DEFINE([INCLUDE_DEBUG_LOGGING], 1, [Debug message logging (toggable)])
+ fi
fi
# Examples build