summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPete Batard <pbatard@gmail.com>2010-01-19 00:55:30 +0000
committerPete Batard <pbatard@gmail.com>2010-01-19 00:55:30 +0000
commite158221159aebdc6a1c6eb9d56ac258a5e69ab32 (patch)
tree6ed40ff464161d19b92678bcc22ecc3dc52e3413 /configure.ac
parent7a8f7d1826c754aed2a4ae5f369b8882cc4cb884 (diff)
downloadlibusb-e158221159aebdc6a1c6eb9d56ac258a5e69ab32.tar.gz
r90: more compilation environment fixes:
- added Visual Studio 2005 (MSVC8) solution and project files (Orin Eman) - renamed VS 2008 solution and project files - fixed "warning: undefined symbols not allowed" for MinGW/cygwin in configure.ac
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 5aea8b2..e578a58 100644
--- a/configure.ac
+++ b/configure.ac
@@ -39,7 +39,7 @@ case $host in
backend="windows"
LIBS="-lpthreadGC2 -lsetupapi -lole32"
AM_CFLAGS="-Wshadow"
- AM_LDFLAGS=""
+ AM_LDFLAGS="-no-undefined"
;;
*-cygwin*)
AC_DEFINE(OS_WINDOWS, [], [Windows backend])
@@ -48,7 +48,7 @@ case $host in
backend="windows"
LIBS="-lpthread -lsetupapi -lole32"
AM_CFLAGS=""
- AM_LDFLAGS=""
+ AM_LDFLAGS="-no-undefined"
;;
*)
AC_MSG_ERROR([unsupported operating system])