summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorMatt Fischer <matt.fischer@garmin.com>2013-04-15 09:44:48 -0500
committerMatt Fischer <matt.fischer@garmin.com>2013-04-19 16:46:24 -0500
commitabb0957198be8cb34c4dfa0dfd7e7eee13055f09 (patch)
tree23dfcdb8f5e86da4f775903ba469eda6e2c8926d /tests/Makefile.am
parentbecfc2312367ee47993495745ec96d7be1a3b3ba (diff)
downloadlibunwind-abb0957198be8cb34c4dfa0dfd7e7eee13055f09.tar.gz
Added --enable-ptrace
This change adds a manual override to control building of the ptrace library, similar to the existing --enable-coredump option. The default is set based on the existence of sys/ptrace.h, allowing it to be automatically disabled for platforms that do not have ptrace.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am14
1 files changed, 9 insertions, 5 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index a7700622..fc5529d9 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -36,7 +36,7 @@ if USE_ALTIVEC
endif #USE_ALTIVEC
endif #ARCH_PPC64
endif #!ARCH_IA64
- check_SCRIPTS_cdep = run-ptrace-mapper run-ptrace-misc
+ check_SCRIPTS_cdep =
check_PROGRAMS_cdep = Gtest-bt Ltest-bt Gtest-exc Ltest-exc \
Gtest-init Ltest-init \
Gtest-concurrent Ltest-concurrent \
@@ -45,12 +45,16 @@ endif #!ARCH_IA64
Gtest-dyn1 Ltest-dyn1 \
Gtest-trace Ltest-trace \
test-async-sig test-flush-cache test-init-remote \
- test-mem test-setjmp test-ptrace Ltest-varargs \
+ test-mem test-setjmp Ltest-varargs \
Ltest-nomalloc Ltest-nocalloc Lrs-race
- noinst_PROGRAMS_cdep = forker crasher mapper test-ptrace-misc \
- Gperf-simple Lperf-simple
+ noinst_PROGRAMS_cdep = forker crasher Gperf-simple Lperf-simple \
+ Gperf-trace Lperf-trace
- noinst_PROGRAMS_cdep += Gperf-trace Lperf-trace
+if BUILD_PTRACE
+ check_SCRIPTS_cdep += run-ptrace-mapper run-ptrace-misc
+ check_PROGRAMS_cdep += test-ptrace
+ noinst_PROGRAMS_cdep += mapper test-ptrace-misc
+endif
if SUPPORT_CXX_EXCEPTIONS
check_PROGRAMS_cdep += Ltest-cxx-exceptions