summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorJose Flavio Aguilar Paulino <jflavio@br.ibm.com>2007-08-06 20:23:42 -0600
committerDavid Mosberger-Tang <davidm@koala.mostang.com>2007-08-06 20:23:42 -0600
commita1e7ee48365a76804361e891c4b4d1f13c78c20a (patch)
tree4f48258617e19821a7fbb1530da4a408dd2b4bd0 /tests/Makefile.am
parent5c95d139dfa3de77e38877965192430600602f3d (diff)
downloadlibunwind-a1e7ee48365a76804361e891c4b4d1f13c78c20a.tar.gz
Just a small patch to build system, it helps if you build in a power
without altivec.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 4866f473..073a33cd 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -27,7 +27,10 @@ if ARCH_IA64
ia64-test-setjmp ia64-test-sig
else
if ARCH_PPC64
- noinst_PROGRAMS_arch = ppc64-test-altivec ppc64-test-wchar
+if USE_ALTIVEC
+ noinst_PROGRAMS_arch_altivec = ppc64-test-altivec ppc64-test-wchar
+endif #USE_ALTIVEC
+ noinst_PROGRAMS_arch = $(noinst_PROGRAMS_arch_altivec) ppc64-test-wchar
endif #ARCH_PPC64
endif #ARCH_IA64
check_SCRIPTS_cdep = run-ptrace-mapper run-ptrace-misc