summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorArun Sharma <asharma@fb.com>2012-03-29 11:35:26 -0700
committerArun Sharma <asharma@fb.com>2012-03-29 11:35:26 -0700
commit9507a9b5018b8be16d2b62531715f1d1e2999f4a (patch)
tree193de118d224cf2ba115ca2aa58c846b0932b90d /src/Makefile.am
parentbc056ffc9fc47103c04db7fd3bb03c39b2bf1766 (diff)
downloadlibunwind-9507a9b5018b8be16d2b62531715f1d1e2999f4a.tar.gz
ia64: move ia64 specific code out of dwarf
We still need to fixup the callers to pick dwarf_find_unwind_table vs ia64_find_unwind_table in a target dependent way.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 11c7b499..af8d5781 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -191,7 +191,7 @@ libunwind_la_SOURCES_ia64 = $(libunwind_la_SOURCES_ia64_common) \
ia64/Lglobal.c ia64/Linit.c ia64/Linit_local.c ia64/Linit_remote.c \
ia64/Linstall_cursor.S ia64/Lis_signal_frame.c ia64/Lparser.c \
ia64/Lrbs.c ia64/Lregs.c ia64/Lresume.c ia64/Lscript.c ia64/Lstep.c \
- ia64/Ltables.c
+ ia64/Ltables.c ia64/Lfind_unwind_tables.c
# The list of files that go into libunwind-ia64:
libunwind_ia64_la_SOURCES_ia64 = $(libunwind_la_SOURCES_ia64_common) \
@@ -200,7 +200,7 @@ libunwind_ia64_la_SOURCES_ia64 = $(libunwind_la_SOURCES_ia64_common) \
ia64/Gglobal.c ia64/Ginit.c ia64/Ginit_local.c ia64/Ginit_remote.c \
ia64/Ginstall_cursor.S ia64/Gis_signal_frame.c ia64/Gparser.c \
ia64/Grbs.c ia64/Gregs.c ia64/Gresume.c ia64/Gscript.c ia64/Gstep.c \
- ia64/Gtables.c
+ ia64/Gtables.c ia64/Gfind_unwind_tables.c
# The list of files that go both into libunwind and libunwind-hppa:
noinst_HEADERS += hppa/init.h hppa/offsets.h hppa/unwind_i.h