summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorKonstantin Belousov <kostik@pooma.home>2010-03-06 00:41:37 +0200
committerKonstantin Belousov <kostik@pooma.home>2010-03-06 00:41:37 +0200
commit905034ce728e84b2a1652ac4b44a2d8a5147a0d1 (patch)
tree160158ac1a0d95c1c1d927ebda5751b484b42b4e /src/Makefile.am
parent46ea10680d689fed15e2bbeed534c0c52059e0ec (diff)
downloadlibunwind-905034ce728e84b2a1652ac4b44a2d8a5147a0d1.tar.gz
Initial attempt at the build infrastructure for FreeBSD.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index c110e768..4ba1b027 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -351,6 +351,11 @@ if OS_HPUX
libunwind_la_SOURCES_os_local = $(libunwind_la_SOURCES_os_hpux_local)
endif
+if OS_FREEBSD
+ libunwind_la_SOURCES_os = $(libunwind_la_SOURCES_os_freebsd)
+ libunwind_la_SOURCES_os_local = $(libunwind_la_SOURCES_os_freebsd_local)
+endif
+
if ARCH_ARM
lib_LTLIBRARIES_arch = libunwind-arm.la
libunwind_la_SOURCES = $(libunwind_la_SOURCES_arm)