summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorZhi-Gang Liu <zliu@tilera.com>2014-09-02 17:35:41 -0400
committerZhi-Gang Liu <zliu@tilera.com>2014-09-08 16:21:53 -0400
commit790be1e40d4c27c4aa1c3160722673ac3e1bbaaf (patch)
tree660b60f35f5a2a832e120112bd62789d3317345a /configure.ac
parent4791a76d26ffb65d56aa16f6b760aa1ee7abdc14 (diff)
downloadlibunwind-790be1e40d4c27c4aa1c3160722673ac3e1bbaaf.tar.gz
Add TileGx platform support to libunwind.
"make check" passed. ====================================================== All 34 tests behaved as expected (2 expected failures) ====================================================== Zhi-Gang Liu @ Tilera
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 5 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index a77cf01e..582e71fc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -95,6 +95,7 @@ AC_DEFUN([SET_ARCH],[
[powerpc*],[$2=ppc$ppc_bits],
[sh*],[$2=sh],
[amd64],[$2=x86_64],
+ [tile*],[$2=tilegx],
[$2=$1])
]) dnl SET_ARCH
@@ -104,7 +105,7 @@ SET_ARCH([$target_cpu],[target_arch])
AC_ARG_ENABLE(coredump,
AS_HELP_STRING([--enable-coredump],[building libunwind-coredump library]),,
- [AS_CASE([$host_arch], [aarch64*|arm*|mips*|sh*|x86*], [enable_coredump=yes], [enable_coredump=no])]
+ [AS_CASE([$host_arch], [aarch64*|arm*|mips*|sh*|x86*|tile*], [enable_coredump=yes], [enable_coredump=no])]
)
AC_MSG_CHECKING([if we should build libunwind-coredump])
@@ -149,6 +150,7 @@ AM_CONDITIONAL(ARCH_X86_64, test x$target_arch = xx86_64)
AM_CONDITIONAL(ARCH_PPC32, test x$target_arch = xppc32)
AM_CONDITIONAL(ARCH_PPC64, test x$target_arch = xppc64)
AM_CONDITIONAL(ARCH_SH, test x$target_arch = xsh)
+AM_CONDITIONAL(ARCH_TILEGX, test x$target_arch = xtilegx)
AM_CONDITIONAL(OS_LINUX, expr x$target_os : xlinux >/dev/null)
AM_CONDITIONAL(OS_HPUX, expr x$target_os : xhpux >/dev/null)
AM_CONDITIONAL(OS_FREEBSD, expr x$target_os : xfreebsd >/dev/null)
@@ -157,7 +159,7 @@ AM_CONDITIONAL(OS_QNX, expr x$target_os : xnto-qnx >/dev/null)
AC_MSG_CHECKING([for ELF helper width])
case "${target_arch}" in
(arm|hppa|ppc32|x86|sh) use_elf32=yes; AC_MSG_RESULT([32]);;
-(aarch64|ia64|ppc64|x86_64) use_elf64=yes; AC_MSG_RESULT([64]);;
+(aarch64|ia64|ppc64|x86_64|tilegx) use_elf64=yes; AC_MSG_RESULT([64]);;
(mips) use_elfxx=yes; AC_MSG_RESULT([xx]);;
*) AC_MSG_ERROR([Unknown ELF target: ${target_arch}])
esac
@@ -209,6 +211,7 @@ case $target_arch in
aarch64*) enable_cxx_exceptions=no;;
arm*) enable_cxx_exceptions=no;;
mips*) enable_cxx_exceptions=no;;
+ tile*) enable_cxx_exceptions=no;;
*) enable_cxx_exceptions=yes;;
esac
])